summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD34
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e38ddde422b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = canto-curses-git
+ pkgdesc = ncurses user interface for canto-daemon/canto-next. Git version
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = http://codezen.org/canto-ng/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = ncurses
+ depends = readline
+ depends = canto-daemon>=0.9.1
+ provides = canto-curses=0.9.3
+ conflicts = canto-curses
+ source = git://github.com/themoken/canto-curses#branch=master
+ md5sums = SKIP
+
+pkgname = canto-curses-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f3bc2f51a55e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*/src
+*/pkg
+*.gz
+*.xz
+*.bz2
+*.zip
+*.part
+*.sig
+*.sign
+*.txt
+*.log
+*.scm
+*/canto-curses
+*/*.pkg
+*/*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4c5b115b8dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lex Black <autumn-wind at web dot de>
+
+_pkgname=canto-curses
+pkgname=canto-curses-git
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="ncurses user interface for canto-daemon/canto-next. Git version"
+url="http://codezen.org/canto-ng/"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('ncurses' 'readline' 'canto-daemon>=0.9.1')
+makedepends=('git')
+conflicts=('canto-curses')
+provides=('canto-curses=0.9.3')
+source=('git://github.com/themoken/canto-curses#branch=master')
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//'
+}
+
+build() {
+ cd $srcdir/$_pkgname
+
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_pkgname
+
+ python setup.py install --prefix=/usr --root=${pkgdir} #--optimize=1
+}