summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--arch-ghc.patch12
3 files changed, 8 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8aa24bd95479..22c1087a378a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = cardano-addresses
pkgdesc = Addresses and mnemonic manipulation & derivations for Cardano blockchain platform
- pkgver = 3.2.0
+ pkgver = 3.4.0
pkgrel = 1
url = https://github.com/input-output-hk/cardano-addresses
arch = any
license = Apache
makedepends = cabal-install-bin
- makedepends = ghc-8.6=8.6.5
- source = https://github.com/input-output-hk/cardano-addresses/archive/3.2.0.zip
- source = arch-ghc.patch
- sha256sums = c8c03e1a9cfc872683b30236fe7c26b8a6edb843902934ade8e1e006bb6d7e45
- sha256sums = 948405ebe0abbf758bc038926fc00494e7ced7be2bd607af7107b107991ee637
+ makedepends = ghc8.6-bin=8.6.5
+ source = https://github.com/input-output-hk/cardano-addresses/archive/3.4.0.zip
+ sha256sums = 16e7e90fe91796ba8a1c95ae5e542f87719ed4fac8178e9d4b681369a49495c3
pkgname = cardano-addresses
diff --git a/PKGBUILD b/PKGBUILD
index 72d45c4a3982..2a16fb148ca6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,18 @@
# Maintainer: Michał Sałaban <michal@salaban.info>
pkgname=cardano-addresses
-pkgver=3.2.0
+pkgver=3.4.0
pkgrel=1
pkgdesc='Addresses and mnemonic manipulation & derivations for Cardano blockchain platform'
license=('Apache')
arch=('any')
url='https://github.com/input-output-hk/cardano-addresses'
-makedepends=('cabal-install-bin' 'ghc-8.6=8.6.5')
+makedepends=('cabal-install-bin' 'ghc8.6-bin=8.6.5')
_ghc_version="8.6.5"
-source=("https://github.com/input-output-hk/${pkgname}/archive/${pkgver}.zip"
- "arch-ghc.patch")
-sha256sums=(
- "c8c03e1a9cfc872683b30236fe7c26b8a6edb843902934ade8e1e006bb6d7e45"
- "948405ebe0abbf758bc038926fc00494e7ced7be2bd607af7107b107991ee637")
+source=("https://github.com/input-output-hk/${pkgname}/archive/${pkgver}.zip")
+sha256sums=("16e7e90fe91796ba8a1c95ae5e542f87719ed4fac8178e9d4b681369a49495c3")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < ../arch-ghc.patch
cabal configure
cabal clean
cabal update
diff --git a/arch-ghc.patch b/arch-ghc.patch
deleted file mode 100644
index bd44a8bee173..000000000000
--- a/arch-ghc.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nurwa cardano-addresses-3.2.0/cabal.project cardano-addresses-3.2.0-ghc8.6/cabal.project
---- cardano-addresses-3.2.0/cabal.project
-+++ cardano-addresses-3.2.0-ghc8.6/cabal.project
-@@ -2,7 +2,7 @@
-
- index-state: 2020-10-15T08:46:53Z
-
--with-compiler: ghc-8.6.5
-+with-compiler: /opt/ghc-8.6/bin/ghc-8.6.5
-
- packages:
- core/