summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD47
-rw-r--r--cardboard.install4
-rw-r--r--cardboardrc24
4 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f29473b755d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = cardboard-git
+ pkgdesc = A unique, scrollable tiling Wayland compositor designed with laptops in mind.
+ pkgver = r300.f2ef2ff
+ pkgrel = 1
+ url = https://gitlab.com/cardboardwm/cardboard
+ install = cardboard.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = wayland-protocols
+ depends = libdrm
+ depends = libinput
+ depends = wayland
+ depends = xcb-util-wm
+ depends = xorg-server-xwayland
+ optdepends = dmenu: Application launcher
+ optdepends = grim: Screenshot utility
+ optdepends = mako: Lightweight notification daemon
+ optdepends = slurp: Select a region
+ optdepends = swaybg: Set background
+ optdepends = swayidle: Idle management daemon
+ optdepends = swaylock: Screen locker
+ optdepends = waybar: Highly customizable bar
+ provides = cardboard
+ conflicts = cardboard
+ source = git+https://gitlab.com/cardboardwm/cardboard.git
+ source = cardboardrc
+ sha512sums = SKIP
+ sha512sums = 351d5b3b96032586cf36f56f640146df8c873b641406bedf13d081e0c99fdd45dd4f9d2771c8d2cdac6cd1365e310285e8a07bdd7355a3788069c18b6b4ec106
+
+pkgname = cardboard-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9404279a68e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Zom <zomaur at eevul dot org>
+pkgname=cardboard-git
+_pkgname=cardboard
+pkgver=r300.f2ef2ff
+pkgrel=1
+license=("GPL3")
+pkgdesc="A unique, scrollable tiling Wayland compositor designed with laptops in mind."
+makedepends=(git meson ninja wayland-protocols)
+depends=(libdrm libinput wayland xcb-util-wm xorg-server-xwayland)
+optdepends=(
+ "dmenu: Application launcher"
+ "grim: Screenshot utility"
+ "mako: Lightweight notification daemon"
+ "slurp: Select a region"
+ "swaybg: Set background"
+ "swayidle: Idle management daemon"
+ "swaylock: Screen locker"
+ "waybar: Highly customizable bar"
+)
+arch=("i686" "x86_64")
+url="https://gitlab.com/cardboardwm/cardboard"
+source=("git+https://gitlab.com/cardboardwm/cardboard.git"
+cardboardrc)
+sha512sums=('SKIP'
+'351d5b3b96032586cf36f56f640146df8c873b641406bedf13d081e0c99fdd45dd4f9d2771c8d2cdac6cd1365e310285e8a07bdd7355a3788069c18b6b4ec106')
+provides=("cardboard")
+conflicts=("cardboard")
+install=cardboard.install
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ meson --prefix /usr build
+ ninja -C build
+}
+
+package() {
+ install -Dm755 cardboardrc -t "$pkgdir/usr/share/$pkgname/"
+ cd "$_pkgname"
+ DESTDIR="$pkgdir" meson install -C build
+ rm -r "$pkgdir/usr/include/wlr" "$pkgdir/usr/lib/pkgconfig"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/cardboard.install b/cardboard.install
new file mode 100644
index 000000000000..577b3a5a64bb
--- /dev/null
+++ b/cardboard.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Cardboard will try to run ~/.config/cardboard/cardboardrc on startup."
+ echo "A sample script is provided in /usr/share/cardboard/"
+}
diff --git a/cardboardrc b/cardboardrc
new file mode 100644
index 000000000000..9cc8e72c99c2
--- /dev/null
+++ b/cardboardrc
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+mod=alt
+
+cutter config mouse_mod $mod
+
+cutter bind $mod+x quit
+cutter bind $mod+return exec sakura
+cutter bind $mod+left focus left
+cutter bind $mod+right focus right
+cutter bind $mod+shift+left move -10 0
+cutter bind $mod+shift+right move 10 0
+cutter bind $mod+shift+up move 0 -10
+cutter bind $mod+shift+down move 0 10
+cutter bind $mod+w close
+for i in $(seq 1 6); do
+ cutter bind $mod+$i workspace switch $(( i - 1 ))
+ cutter bind $mod+ctrl+$i workspace move $(( i - 1 ))
+done
+
+cutter bind $mod+shift+space toggle_floating
+
+cutter exec toolbox run swaybg -i ~/wallpapers/autobahn.png
+cutter exec toolbox run waybar