summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e3fde313899..b4790f1a8ac5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cargo-binutils
pkgdesc = Cargo subcommands to invoke the LLVM tools shipped with the Rust toolchain
- pkgver = 0.2.0
- pkgrel = 2
+ pkgver = 0.3.3
+ pkgrel = 1
url = https://github.com/rust-embedded/cargo-binutils
install = cargo-binutils.install
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = cargo-binutils
license = MIT
depends = rust
depends = cargo
- source = https://github.com/rust-embedded/cargo-binutils/archive/v0.2.0.tar.gz
- sha256sums = a9f6e581e8f00dc98d043218ee2c36eb7d8b21398a1b97f24100dbe6e2084846
+ source = https://github.com/rust-embedded/cargo-binutils/archive/v0.3.3.tar.gz
+ sha256sums = 91b37bc56ac50fdd5e96a37de39b42cc01351b1e3e775bfc5b875f0e51eaf9fe
pkgname = cargo-binutils
diff --git a/PKGBUILD b/PKGBUILD
index 6173130bafbd..32cd4e07b53d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=cargo-binutils
-pkgver=0.2.0
-pkgrel=2
+pkgver=0.3.3
+pkgrel=1
pkgdesc='Cargo subcommands to invoke the LLVM tools shipped with the Rust toolchain'
url="https://github.com/rust-embedded/$pkgname"
arch=('x86_64')
@@ -8,7 +8,7 @@ license=('Apache' 'MIT')
depends=('rust' 'cargo')
install="$pkgname.install"
source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('a9f6e581e8f00dc98d043218ee2c36eb7d8b21398a1b97f24100dbe6e2084846')
+sha256sums=('91b37bc56ac50fdd5e96a37de39b42cc01351b1e3e775bfc5b875f0e51eaf9fe')
build() {
cd "$pkgname-$pkgver"
@@ -18,7 +18,13 @@ build() {
package() {
cd "$pkgname-$pkgver"
- for binary in 'nm' 'objcopy' 'objdump' 'profdata' 'readobj' 'size' 'strip'; do
+ for binary in 'ar' 'cov' 'ld' 'lld' 'nm' 'objcopy' 'objdump' 'profdata' 'readobj' 'size' 'strip'
+ do
+ install -Dm755 "target/release/rust-$binary" "$pkgdir/usr/bin/rust-$binary"
+ done
+
+ for binary in 'cov' 'nm' 'objcopy' 'objdump' 'profdata' 'readobj' 'size' 'strip'
+ do
install -Dm755 "target/release/cargo-$binary" "$pkgdir/usr/bin/cargo-$binary"
done
}