summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.index.json4
-rw-r--r--PKGBUILD24
-rw-r--r--fix-libgit2-1.5-compat.patch93
4 files changed, 13 insertions, 125 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fac2eb9c5965..3d269cd6c098 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cargo-doc2readme
pkgdesc = cargo subcommand to create a readme file containing the rustdoc comments from...
- pkgver = 0.1.7
+ pkgver = 0.2.0
pkgrel = 1
url = https://crates.io/crates/cargo-doc2readme
arch = aarch64
@@ -8,17 +8,8 @@ pkgbase = cargo-doc2readme
arch = x86_64
license = Apache
makedepends = cargo
- makedepends = libgit2
depends = gcc-libs
- depends = curl
- depends = libgit2.so=1.5
- source = cargo-doc2readme-0.1.7.tar.gz::https://crates.io/api/v1/crates/cargo-doc2readme/0.1.7/download
- source = https://github.com/rust-lang/cargo/archive/refs/heads/rust-1.64.0.zip
- source = https://github.com/rust-lang/cargo/pull/11004.patch
- source = fix-libgit2-1.5-compat.patch
- sha512sums = 9f9516aee6287c58a42dab3e3047976fa6a3e2d240ce07b126697f801cb93a5eafb33dd66955ff7a79e2d9357c45ab772468fc4665d05328681ee6a9c08f41be
- sha512sums = b3de32f0b0e82230d5feb0d1eae35f1b1c7a11bd6e2d9c2d659a0715690c5e98ce02a51a4a1d78d8ed17df8f6a3fd8416eb380d7ab1628820fc521c663bfe68f
- sha512sums = ed4b148bbbdc26059278d9170d377f36b4847d3c253fa4e3549354de8e17bb2849a6541048a9438f1880f003c8debea9766737773c856c9acec31b90fb60553f
- sha512sums = 547046415d7a97ef55a0d5cd9b740af2b5943a5f56feb999cb3d863970b76a934b269b018829a0594d368265c65edda7d9373e2df029435e87204d4214383160
+ source = cargo-doc2readme-0.2.0.tar.gz::https://crates.io/api/v1/crates/cargo-doc2readme/0.2.0/download
+ sha512sums = 565f534badb7bbe5ff877975070c17428d5d41c5386f209f22dcd4df20ddce1be791be5a8cba4105610bcf6d4ca1fcd9810d9e1823d87d01090e666c164b1df6
-pkgname = cargo-doc2readme
+pkgname = cargo-doc2readme \ No newline at end of file
diff --git a/.index.json b/.index.json
index c9baa07d7a24..0dac173a459b 100644
--- a/.index.json
+++ b/.index.json
@@ -1,4 +1,4 @@
{
"crate": "cargo-doc2readme",
- "version": "0.1.7"
-}
+ "version": "0.2.0"
+} \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 6589d3ca9d9c..ad07e62b3601 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,39 +3,29 @@
_crate="cargo-doc2readme"
pkgname="cargo-doc2readme"
-pkgver=0.1.7
+pkgver=0.2.0
pkgrel=1
pkgdesc='cargo subcommand to create a readme file containing the rustdoc comments from...'
url='https://crates.io/crates/cargo-doc2readme'
license=('Apache')
-depends=('gcc-libs' 'curl' 'libgit2.so=1.5')
-makedepends=('cargo' 'libgit2')
+depends=('gcc-libs')
+makedepends=('cargo')
-source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/cargo-doc2readme/$pkgver/download"
- "https://github.com/rust-lang/cargo/archive/refs/heads/rust-1.64.0.zip"
- "https://github.com/rust-lang/cargo/pull/11004.patch"
- "fix-libgit2-1.5-compat.patch")
-sha512sums=('9f9516aee6287c58a42dab3e3047976fa6a3e2d240ce07b126697f801cb93a5eafb33dd66955ff7a79e2d9357c45ab772468fc4665d05328681ee6a9c08f41be'
- 'b3de32f0b0e82230d5feb0d1eae35f1b1c7a11bd6e2d9c2d659a0715690c5e98ce02a51a4a1d78d8ed17df8f6a3fd8416eb380d7ab1628820fc521c663bfe68f'
- 'ed4b148bbbdc26059278d9170d377f36b4847d3c253fa4e3549354de8e17bb2849a6541048a9438f1880f003c8debea9766737773c856c9acec31b90fb60553f'
- '547046415d7a97ef55a0d5cd9b740af2b5943a5f56feb999cb3d863970b76a934b269b018829a0594d368265c65edda7d9373e2df029435e87204d4214383160')
+source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/cargo-doc2readme/0.2.0/download")
+sha512sums=('565f534badb7bbe5ff877975070c17428d5d41c5386f209f22dcd4df20ddce1be791be5a8cba4105610bcf6d4ca1fcd9810d9e1823d87d01090e666c164b1df6')
# Tier 1 architectures supported by Rust (https://doc.rust-lang.org/nightly/rustc/platform-support.html#tier-1)
arch=('aarch64' 'i686' 'x86_64')
prepare() {
- cd "$srcdir/cargo-rust-1.64.0"
- patch -N -p1 -i "$srcdir/11004.patch"
-
cd "$srcdir/$_crate-$pkgver"
- patch -N -p1 -i "$srcdir/fix-libgit2-1.5-compat.patch"
+
cargo fetch --locked
}
build() {
cd "$srcdir/$_crate-$pkgver"
- LIBSSH2_SYS_USE_PKG_CONFIG='1' \
cargo build \
--offline \
--locked \
@@ -45,4 +35,4 @@ build() {
package() {
cd "$srcdir/$_crate-$pkgver"
install -Dm755 "target/release/cargo-doc2readme" -t "$pkgdir/usr/bin"
-}
+} \ No newline at end of file
diff --git a/fix-libgit2-1.5-compat.patch b/fix-libgit2-1.5-compat.patch
deleted file mode 100644
index 24a710dcef7a..000000000000
--- a/fix-libgit2-1.5-compat.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-diff --git a/Cargo.lock b/Cargo.lock
-index a848a5a..a14c5e6 100644
---- a/Cargo.lock
-+++ b/Cargo.lock
-@@ -170,8 +170,6 @@ checksum = "6c58ec36aac5066d5ca17df51b3e70279f5670a72102f5752cb7e7c856adfc70"
- [[package]]
- name = "cargo"
- version = "0.65.0"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "988ba7aa82c0944fd91d119ee24a5c1f865eb2797e0edd90f6c08c7252857ca5"
- dependencies = [
- "anyhow",
- "atty",
-@@ -259,8 +257,6 @@ dependencies = [
- [[package]]
- name = "cargo-platform"
- version = "0.1.2"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "cbdb825da8a5df079a43676dbe042702f1707b1109f713a01420fbb4cc71fa27"
- dependencies = [
- "serde",
- ]
-@@ -268,8 +264,6 @@ dependencies = [
- [[package]]
- name = "cargo-util"
- version = "0.2.1"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "eb66f33d96c58d1eef3a4744556ce0fae012b01165a3f171169a15cb4efc9633"
- dependencies = [
- "anyhow",
- "core-foundation",
-@@ -394,8 +388,6 @@ checksum = "5827cebf4670468b8772dd191856768aedcb1b0278a04f989f7766351917b9dc"
- [[package]]
- name = "crates-io"
- version = "0.34.0"
--source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "6b4a87459133b2e708195eaab34be55039bc30e0d120658bd40794bb00b6328d"
- dependencies = [
- "anyhow",
- "curl",
-@@ -632,9 +624,9 @@ dependencies = [
-
- [[package]]
- name = "git2"
--version = "0.14.4"
-+version = "0.15.0"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "d0155506aab710a86160ddb504a480d2964d7ab5b9e62419be69e0032bc5931c"
-+checksum = "2994bee4a3a6a51eb90c218523be382fd7ea09b16380b9312e9dbe955ff7c7d1"
- dependencies = [
- "bitflags",
- "libc",
-@@ -647,9 +639,9 @@ dependencies = [
-
- [[package]]
- name = "git2-curl"
--version = "0.15.0"
-+version = "0.16.0"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "1ee51709364c341fbb6fe2a385a290fb9196753bdde2fc45447d27cd31b11b13"
-+checksum = "ed817a00721e2f8037ba722e60358d4956dae9cca10315fc982f967907d3b0cd"
- dependencies = [
- "curl",
- "git2",
-@@ -865,9 +857,9 @@ checksum = "349d5a591cd28b49e1d1037471617a32ddcda5731b99419008085f72d5a53836"
-
- [[package]]
- name = "libgit2-sys"
--version = "0.13.4+1.4.2"
-+version = "0.14.0+1.5.0"
- source = "registry+https://github.com/rust-lang/crates.io-index"
--checksum = "d0fa6563431ede25f5cc7f6d803c6afbc1c5d3ad3d4925d12c882bf2b526f5d1"
-+checksum = "47a00859c70c8a4f7218e6d1cc32875c4b55f6799445b842b0d8ed5e4c3d959b"
- dependencies = [
- "cc",
- "libc",
-diff --git a/Cargo.toml b/Cargo.toml
-index 8b0b81d..403202f 100644
---- a/Cargo.toml
-+++ b/Cargo.toml
-@@ -65,7 +65,7 @@
- version = "1.6"
-
- [dependencies.git2-curl]
--version = "0.15"
-+version = "0.16"
-
- [dependencies.itertools]
- version = "0.10"
-@@ -122,0 +122,3 @@
-+
-+[patch.crates-io]
-+cargo = { path = "../cargo-rust-1.64.0" }