summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58c859c260f3..e95e4a89b3a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cargo-llvm-lines
pkgdesc = Count the number of lines of LLVM IR across all instantiations of a generic function
- pkgver = 0.4.7
- pkgrel = 2
+ pkgver = 0.4.8
+ pkgrel = 1
url = https://github.com/dtolnay/cargo-llvm-lines
arch = any
license = Apache
@@ -9,8 +9,8 @@ pkgbase = cargo-llvm-lines
depends = cargo
depends = rust-nightly
depends = rustfmt
- source = cargo-llvm-lines-0.4.7.tar.gz::https://github.com/dtolnay/cargo-llvm-lines/archive/0.4.7.tar.gz
- sha256sums = 80b59e77dee53834dd2b0769f5719fc053c197c8d452a561de4998cc99f65b92
+ source = cargo-llvm-lines-0.4.8.tar.gz::https://github.com/dtolnay/cargo-llvm-lines/archive/0.4.8.tar.gz
+ sha256sums = 9988e22deb9457e9aea82bc9b28fa7c73b0ea93dba361b5b4e8760e49cd9dcdd
pkgname = cargo-llvm-lines
diff --git a/PKGBUILD b/PKGBUILD
index e01fb219c396..e667af22c93a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Maintainer: Jonas Malaco <jonas@protocubo.io>
pkgname=cargo-llvm-lines
-pkgver=0.4.7
-pkgrel=2
+pkgver=0.4.8
+pkgrel=1
pkgdesc="Count the number of lines of LLVM IR across all instantiations of a generic function"
arch=('any')
url='https://github.com/dtolnay/cargo-llvm-lines'
license=('Apache' 'MIT')
depends=('cargo' 'rust-nightly' 'rustfmt')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('80b59e77dee53834dd2b0769f5719fc053c197c8d452a561de4998cc99f65b92')
+sha256sums=('9988e22deb9457e9aea82bc9b28fa7c73b0ea93dba361b5b4e8760e49cd9dcdd')
build() {
cd "$pkgname-$pkgver"
- # note: upstream does not provide Cargo.lock
- cargo build --release --all-features --target-dir=target
+ cargo build --release --locked --all-features --target-dir=target
}
check() {