summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15fd490d78a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cashshuffle
+ pkgdesc = CashShuffle server for BCH.
+ pkgver = 0.4.3
+ pkgrel = 0
+ url = http://github.com/cashshuffle/cashshuffle
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ provides = s=0.4.3
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/cashshuffle/cashshuffle/archive/v0.4.3.tar.gz
+ sha256sums = 1b8acd595a9589ac0f42590f7ba8936b33ddfc4c4e6c1b9e5819a0ff324ab634
+
+pkgname = cashshuffle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a1d72792c24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Josh Ellithorpe <quest at mac dot com>
+
+pkgname=cashshuffle
+pkgver=0.4.3
+pkgrel=0
+pkgdesc="CashShuffle server for BCH."
+arch=('i686' 'x86_64')
+url="http://github.com/cashshuffle/cashshuffle"
+license=('MIT')
+makedepends=('go' 'git')
+options=('!strip' '!emptydirs')
+provides=("s=${pkgver}")
+source=("https://github.com/cashshuffle/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('1b8acd595a9589ac0f42590f7ba8936b33ddfc4c4e6c1b9e5819a0ff324ab634')
+
+build() {
+ mkdir -p "${srcdir}/go/src/github.com/cashshuffle"
+ export GOPATH="${srcdir}/go"
+ export GOBIN="$GOPATH/bin"
+
+ mv "$pkgname-$pkgver" "$GOPATH/src/github.com/cashshuffle/cashshuffle"
+ cd "$GOPATH/src/github.com/cashshuffle/cashshuffle"
+
+ go get -u github.com/FiloSottile/gvt
+ $GOBIN/gvt restore
+
+ go build .
+}
+
+package() {
+ cd "${srcdir}/go/src/github.com/cashshuffle/cashshuffle"
+
+ install -Dm 775 "cashshuffle" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 644 "LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}