summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--renameat2-test-fix.patch7
3 files changed, 17 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5a1bf48ec08..e71b3d347b25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,7 +21,9 @@ pkgbase = casync-git
provides = casync
conflicts = casync
source = casync-git::git+https://github.com/systemd/casync
+ source = renameat2-test-fix.patch
sha256sums = SKIP
+ sha256sums = 3fb0fc4965039d0fc5b51c8fe49bb7ad74108324ff921c6f5b74127036c28d51
pkgname = casync-git
diff --git a/PKGBUILD b/PKGBUILD
index ba111380cfbf..6c9c4af1e2a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,9 @@ optdepends=()
checkdepends=('rsync')
provides=('casync')
conflicts=('casync')
-source=("$pkgname::git+$url")
-sha256sums=('SKIP')
+source=("$pkgname::git+$url" 'renameat2-test-fix.patch')
+sha256sums=('SKIP'
+ '3fb0fc4965039d0fc5b51c8fe49bb7ad74108324ff921c6f5b74127036c28d51')
pkgver() {
cd "$pkgname"
@@ -23,6 +24,11 @@ pkgver() {
)
}
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -p1 -i "$srcdir/renameat2-test-fix.patch"
+}
+
build() {
cd "$srcdir/$pkgname"
arch-meson build/ -Dselinux=false
diff --git a/renameat2-test-fix.patch b/renameat2-test-fix.patch
new file mode 100644
index 000000000000..8022869578b9
--- /dev/null
+++ b/renameat2-test-fix.patch
@@ -0,0 +1,7 @@
+diff --git a/meson.build b/meson.build
+index f42ed16..c0f741e 100644
+--- a/meson.build
++++ b/meson.build
+@@ -81 +81 @@ foreach ident : [
+- have = cc.has_function(ident[0], prefix : ident[1])
++ have = cc.has_function(ident[0], args : '-D_GNU_SOURCE', prefix : ident[1])