summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--4.9_over_4.6-arch-get_user_pages_remote.patch24
-rw-r--r--PKGBUILD11
3 files changed, 35 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f00af6c04bcd..be6f9dc8bb73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = catalyst
pkgdesc = AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
pkgver = 15.9
- pkgrel = 13
+ pkgrel = 14
url = http://www.amd.com
install = catalyst.install
arch = i686
@@ -12,7 +12,7 @@ pkgbase = catalyst
makedepends = make
makedepends = linux-headers
depends = linux>=3.0
- depends = linux<4.9
+ depends = linux<4.10
depends = catalyst-utils
conflicts = catalyst-test
source = http://www2.ati.com/drivers/linux/amd-catalyst-15.9-linux-installer-15.201.1151-x86.x86_64.zip
@@ -29,6 +29,7 @@ pkgbase = catalyst
source = grsec_arch.patch
source = 4.6-arch-get_user_pages-page_cache_release.patch
source = 4.7-arch-cpu_has_pge-v2.patch
+ source = 4.9_over_4.6-arch-get_user_pages_remote.patch
md5sums = d2de2df6946b452c266a3c892e6e46ff
md5sums = fd98b7e486d7fd4cad8de7b95b5b031e
md5sums = 3e1b82bd69774ea808da69c983d6a43b
@@ -43,6 +44,7 @@ pkgbase = catalyst
md5sums = 8941e91fc58cb44ce21ab9bda135754e
md5sums = 11b7c2e0dc4794801005d66b0e7608a3
md5sums = 37eef5103a11d8136979463e7bc31091
+ md5sums = 194cb44e9e2ab0e65b6267aca66d0400
pkgname = catalyst
diff --git a/4.9_over_4.6-arch-get_user_pages_remote.patch b/4.9_over_4.6-arch-get_user_pages_remote.patch
new file mode 100644
index 000000000000..802ca96b6787
--- /dev/null
+++ b/4.9_over_4.6-arch-get_user_pages_remote.patch
@@ -0,0 +1,24 @@
+--- 16.12/common/lib/modules/fglrx/build_mod/firegl_public.c 2016-12-10 19:44:46.764677311 +0100
++++ 16.12b/common/lib/modules/fglrx/build_mod/firegl_public.c 2016-12-10 19:45:43.941354338 +0100
+@@ -3225,7 +3225,9 @@
+ int ret;
+
+ down_read(&current->mm->mmap_sem);
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,6,0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,9,0)
++ ret = get_user_pages_remote(current, current->mm, vaddr, page_cnt, 1, (struct page **)page_list, NULL);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4,6,0)
+ ret = get_user_pages_remote(current, current->mm, vaddr, page_cnt, 1, 0, (struct page **)page_list, NULL);
+ #else
+ ret = get_user_pages(current, current->mm, vaddr, page_cnt, 1, 0, (struct page **)page_list, NULL);
+@@ -3247,7 +3249,9 @@
+ int ret;
+
+ down_read(&current->mm->mmap_sem);
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,6,0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,9,0)
++ ret = get_user_pages_remote(current, current->mm, vaddr, page_cnt, 0, (struct page **)page_list, NULL);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4,6,0)
+ ret = get_user_pages_remote(current, current->mm, vaddr, page_cnt, 0, 0, (struct page **)page_list, NULL);
+ #else
+ ret = get_user_pages(current, current->mm, vaddr, page_cnt, 0, 0, (struct page **)page_list, NULL);
diff --git a/PKGBUILD b/PKGBUILD
index fa6f25ba04d7..a4944dbe4cd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,13 +16,13 @@ _kernver=`uname -r`
pkgname=catalyst
pkgver=15.9
-pkgrel=13
+pkgrel=14
_amdver=15.201.1151
pkgdesc="AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
-depends=('linux>=3.0' 'linux<4.9' 'catalyst-utils')
+depends=('linux>=3.0' 'linux<4.10' 'catalyst-utils')
makedepends=('gcc-libs' 'gcc>4.0.0' 'make' 'linux-headers')
conflicts=('catalyst-test')
install=catalyst.install
@@ -44,7 +44,8 @@ source=(
4.4-manjaro-xstate.patch
grsec_arch.patch
4.6-arch-get_user_pages-page_cache_release.patch
- 4.7-arch-cpu_has_pge-v2.patch)
+ 4.7-arch-cpu_has_pge-v2.patch
+ 4.9_over_4.6-arch-get_user_pages_remote.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'fd98b7e486d7fd4cad8de7b95b5b031e'
@@ -59,7 +60,8 @@ md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'd9bea135ae3e1b3ca87c5bbe6dcf8e72'
'8941e91fc58cb44ce21ab9bda135754e'
'11b7c2e0dc4794801005d66b0e7608a3'
- '37eef5103a11d8136979463e7bc31091')
+ '37eef5103a11d8136979463e7bc31091'
+ '194cb44e9e2ab0e65b6267aca66d0400')
build() {
@@ -94,6 +96,7 @@ build() {
patch -Np1 -i ../grsec_arch.patch
patch -Np1 -i ../4.6-arch-get_user_pages-page_cache_release.patch
patch -Np1 -i ../4.7-arch-cpu_has_pge-v2.patch
+ patch -Np1 -i ../4.9_over_4.6-arch-get_user_pages_remote.patch
cd ${srcdir}/archive_files/common/lib/modules/fglrx/build_mod
cp ${srcdir}/archive_files/arch/${_archdir}/lib/modules/fglrx/build_mod/libfglrx_ip.a .