summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--4.7-arch-cpu_has_pge-v2.patch70
-rw-r--r--PKGBUILD17
3 files changed, 92 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 582559d6aa99..ba908b3b4415 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = catalyst-firepro
pkgdesc = AMD/ATI drivers for FirePro/GL/MV brand cards. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport.
- pkgver = 15.302.2001
+ pkgver = 15.302.2301
pkgrel = 1
url = http://www.amd.com
install = catalyst-firepro.install
@@ -9,7 +9,7 @@ pkgbase = catalyst-firepro
license = custom
depends = dkms
depends = linux>=3.0
- depends = linux<4.7
+ depends = linux<4.8
depends = linux-headers
depends = xorg-server>=1.7.0
depends = xorg-server<1.18.0
@@ -30,12 +30,12 @@ pkgbase = catalyst-firepro
optdepends = acpid: acpi event support / atieventsd
optdepends = procps-ng: brings pgrep used in acpi event support
provides = libgl
- provides = libatical=15.302.2001
- provides = catalyst=15.302.2001
- provides = catalyst-utils=15.302.2001
- provides = catalyst-dkms=15.302.2001
- provides = catalyst-libgl=15.302.2001
- provides = opencl-catalyst=15.302.2001
+ provides = libatical=15.302.2301
+ provides = catalyst=15.302.2301
+ provides = catalyst-utils=15.302.2301
+ provides = catalyst-dkms=15.302.2301
+ provides = catalyst-libgl=15.302.2301
+ provides = opencl-catalyst=15.302.2301
provides = libcl
provides = dri
provides = libtxc_dxtn
@@ -55,7 +55,7 @@ pkgbase = catalyst-firepro
options = libtool
options = !strip
options = !upx
- source = http://www2.ati.com/drivers/firepro/15.302.2001-linux-retail_end_user.zip
+ source = http://www2.ati.com/drivers/firepro/15.302.2301-linux-retail_end_user.zip
source = lib32-catalyst.sh
source = catalyst.sh
source = atieventsd.sh
@@ -80,7 +80,8 @@ pkgbase = catalyst-firepro
source = 4.6-arch-get_user_pages-page_cache_release.patch
source = dkms.conf
source = makesh-dont-check-gcc-version.patch
- md5sums = 09465fd40f60c609c3e56dbbe342a46e
+ source = 4.7-arch-cpu_has_pge-v2.patch
+ md5sums = 211a7e52d032bc60806012a13407ba87
md5sums = af7fb8ee4fc96fd54c5b483e33dc71c4
md5sums = bdafe749e046bfddee2d1c5e90eabd83
md5sums = 9d9ea496eadf7e883d56723d65e96edf
@@ -105,6 +106,7 @@ pkgbase = catalyst-firepro
md5sums = 11b7c2e0dc4794801005d66b0e7608a3
md5sums = 23d569abfdd7de433d76e003e4b3ccf9
md5sums = 10829e3b992b3e80a6e78c8e27748703
+ md5sums = 37eef5103a11d8136979463e7bc31091
pkgname = catalyst-firepro
diff --git a/4.7-arch-cpu_has_pge-v2.patch b/4.7-arch-cpu_has_pge-v2.patch
new file mode 100644
index 000000000000..cb86f5aff276
--- /dev/null
+++ b/4.7-arch-cpu_has_pge-v2.patch
@@ -0,0 +1,70 @@
+diff -uNr 16.8/common/lib/modules/fglrx/build_mod/firegl_public.c 16.8b/common/lib/modules/fglrx/build_mod/firegl_public.c
+--- 16.8/common/lib/modules/fglrx/build_mod/firegl_public.c 2015-12-18 19:47:41.000000000 +0100
++++ 16.8b/common/lib/modules/fglrx/build_mod/firegl_public.c 2016-08-15 15:09:37.228538907 +0200
+@@ -4518,7 +4518,11 @@
+ write_cr0(cr0);
+ wbinvd();
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,7,0)
++ if (boot_cpu_has(X86_FEATURE_PGE))
++#else
+ if (cpu_has_pge)
++#endif
+ {
+ cr4 = READ_CR4();
+ WRITE_CR4(cr4 & ~X86_CR4_PGE);
+@@ -4532,7 +4536,11 @@
+ wbinvd();
+ __flush_tlb();
+ write_cr0(cr0 & 0xbfffffff);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,7,0)
++ if (boot_cpu_has(X86_FEATURE_PGE))
++#else
+ if (cpu_has_pge)
++#endif
+ {
+ WRITE_CR4(cr4);
+ }
+@@ -4559,7 +4567,11 @@
+ write_cr0(cr0);
+ wbinvd();
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,7,0)
++ if (boot_cpu_has(X86_FEATURE_PGE))
++#else
+ if (cpu_has_pge)
++#endif
+ {
+ cr4 = READ_CR4();
+ WRITE_CR4(cr4 & ~X86_CR4_PGE);
+@@ -4572,7 +4584,11 @@
+ wbinvd();
+ __flush_tlb();
+ write_cr0(cr0 & 0xbfffffff);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,7,0)
++ if (boot_cpu_has(X86_FEATURE_PGE))
++#else
+ if (cpu_has_pge)
++#endif
+ {
+ WRITE_CR4(cr4);
+ }
+diff -uNr 16.8/common/lib/modules/fglrx/build_mod/firegl_public.h 16.8b/common/lib/modules/fglrx/build_mod/firegl_public.h
+--- 16.8/common/lib/modules/fglrx/build_mod/firegl_public.h 2015-12-18 19:47:41.000000000 +0100
++++ 16.8b/common/lib/modules/fglrx/build_mod/firegl_public.h 2016-08-15 15:09:05.815141238 +0200
+@@ -650,9 +650,15 @@
+ #define cpu_has_pat test_bit(X86_FEATURE_PAT, (void *) &boot_cpu_data.x86_capability)
+ #endif
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,7,0)
++#ifndef boot_cpu_has(X86_FEATURE_PGE)
++#define boot_cpu_has(X86_FEATURE_PGE) test_bit(X86_FEATURE_PGE, &boot_cpu_data.x86_capability)
++#endif
++#else
+ #ifndef cpu_has_pge
+ #define cpu_has_pge test_bit(X86_FEATURE_PGE, &boot_cpu_data.x86_capability)
+ #endif
++#endif
+
+ /* 2.6.29 defines pgprot_writecombine as a macro which resolves to a
+ * GPL-only function with the same name. So we always use our own
diff --git a/PKGBUILD b/PKGBUILD
index 5408b3bb4ebd..fddb6d82bd2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,16 +26,16 @@
# PKGEXT='.pkg.tar.gz' # imho time to pack this pkg into tar.xz is too long, unfortunatelly yaourt got problems when ext is different from .pkg.tar.xz - V
pkgname=catalyst-firepro
-pkgver=15.302.2001
+pkgver=15.302.2301
pkgrel=1
# _betano=1.0
-_amdver=15.302
+# _amdver=15.302
pkgdesc="AMD/ATI drivers for FirePro/GL/MV brand cards. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport."
arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
options=('staticlibs' 'libtool' '!strip' '!upx')
-depends=('dkms' 'linux>=3.0' 'linux<4.7' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4')
+depends=('dkms' 'linux>=3.0' 'linux<4.8' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4')
optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
@@ -68,7 +68,7 @@ source=(
# http://www2.ati.com/drivers/linux/amd-catalyst-${pkgver/./-}-linux-x86-x86-64.zip
# http://www2.ati.com/drivers/linux/amd-catalyst-omega-14.12-linux-run-installers.zip
# http://www2.ati.com/drivers/linux/amd-driver-installer-${_amdver}-x86.x86_64.zip
- http://www2.ati.com/drivers/firepro/15.302.2001-linux-retail_end_user.zip
+ http://www2.ati.com/drivers/firepro/15.302.2301-linux-retail_end_user.zip
lib32-catalyst.sh
catalyst.sh
atieventsd.sh
@@ -92,9 +92,10 @@ source=(
grsec_arch.patch
4.6-arch-get_user_pages-page_cache_release.patch
dkms.conf
- makesh-dont-check-gcc-version.patch)
+ makesh-dont-check-gcc-version.patch
+ 4.7-arch-cpu_has_pge-v2.patch)
-md5sums=('09465fd40f60c609c3e56dbbe342a46e'
+md5sums=('211a7e52d032bc60806012a13407ba87'
'af7fb8ee4fc96fd54c5b483e33dc71c4'
'bdafe749e046bfddee2d1c5e90eabd83'
'9d9ea496eadf7e883d56723d65e96edf'
@@ -118,7 +119,8 @@ md5sums=('09465fd40f60c609c3e56dbbe342a46e'
'8941e91fc58cb44ce21ab9bda135754e'
'11b7c2e0dc4794801005d66b0e7608a3'
'23d569abfdd7de433d76e003e4b3ccf9'
- '10829e3b992b3e80a6e78c8e27748703')
+ '10829e3b992b3e80a6e78c8e27748703'
+ '37eef5103a11d8136979463e7bc31091')
build() {
@@ -307,6 +309,7 @@ package() {
patch -Np1 -i ../grsec_arch.patch
patch -Np1 -i ../4.6-arch-get_user_pages-page_cache_release.patch
patch -Np1 -i ../makesh-dont-check-gcc-version.patch
+ patch -Np1 -i ../4.7-arch-cpu_has_pge-v2.patch
# Prepare modules source files
install -dm755 ${pkgdir}/usr/src/fglrx-${pkgver}/2.6.x