summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--4.2-kolasa-fpu_save_init.patch34
-rw-r--r--PKGBUILD18
3 files changed, 47 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac7db958690e..64dda12830d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = catalyst-test
pkgdesc = AMD/ATI Catalyst drivers for linux. catalyst-hook + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
pkgver = 15.9
- pkgrel = 1
+ pkgrel = 2
url = http://www.amd.com
install = catalyst-test.install
arch = i686
@@ -81,6 +81,7 @@ pkgbase = catalyst-test
source = ubuntu_buildfix_kernel_4.1.patch
source = ubuntu_buildfix_kernel_4.2.patch
source = 4.2-fglrx-has_fpu.patch
+ source = 4.2-kolasa-fpu_save_init.patch
md5sums = d2de2df6946b452c266a3c892e6e46ff
md5sums = 601d9c756571dd79d26944e54827631e
md5sums = af7fb8ee4fc96fd54c5b483e33dc71c4
@@ -108,6 +109,7 @@ pkgbase = catalyst-test
md5sums = 982451bcc1fa1ee3da53ffa481d65581
md5sums = 88832af8d6769aa51fa9b266a74394e0
md5sums = ed7748a593d6b894269f8c7856b7ae50
+ md5sums = dd51495a1d8f2d1042f04a783bf01e08
pkgname = catalyst-test
diff --git a/4.2-kolasa-fpu_save_init.patch b/4.2-kolasa-fpu_save_init.patch
new file mode 100644
index 000000000000..6d2e4e70c0f5
--- /dev/null
+++ b/4.2-kolasa-fpu_save_init.patch
@@ -0,0 +1,34 @@
+--- 15.9/common/lib/modules/fglrx/build_mod/firegl_public.c 2015-09-20 18:29:19.488890309 +0200
++++ 15.9b/common/lib/modules/fglrx/build_mod/firegl_public.c 2015-09-20 14:20:51.000000000 +0200
+@@ -6505,11 +6505,15 @@
+ struct task_struct *cur_task = get_current();
+ preempt_disable();
+ if (cur_thread->status & TS_USEDFPU)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,2,0)
++ copy_fpregs_to_fpstate(&cur_task->thread.fpu);
++#else
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,15,0)
+ KCL_fpu_save_init(cur_task);
+ #else
+ __save_init_fpu(cur_task);
+ #endif
++#endif
+ else
+ clts();
+
+@@ -6531,11 +6535,15 @@
+ #else
+ if (cur_task->thread.fpu.fpregs_active)
+ #endif
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,2,0)
++ copy_fpregs_to_fpstate(&cur_task->thread.fpu);
++#else
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,15,0)
+ KCL_fpu_save_init(cur_task);
+ #else
+ __save_init_fpu(cur_task);
+ #endif
++#endif
+ else
+ clts();
+ #endif
diff --git a/PKGBUILD b/PKGBUILD
index 4a7837194307..126501514b2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,13 +19,14 @@
# Contributor: zoopp
# Contributor: solar (authatieventsd' patch s/-1/255)
# Contributor: Cold (current_euid patch)
-# Contributor: ubuntu (4.1 kernel patch)
+# Contributor: ubuntu (parts of 4.0, 4.1 and 4.2 kernel patches)
+# Contributor: kolasa (part of 4.2 kernel patches)
# PKGEXT='.pkg.tar.gz' # imho time to pack this pkg into tar.xz is too long, unfortunatelly yaourt got problems when ext is different from .pkg.tar.xz - V
pkgname=catalyst-test
pkgver=15.9
-pkgrel=1
+pkgrel=2
# _betano=1.0
_amdver=15.201.1151
pkgdesc="AMD/ATI Catalyst drivers for linux. catalyst-hook + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
@@ -92,7 +93,8 @@ source=(
ubuntu_buildfix_kernel_4.0.patch
ubuntu_buildfix_kernel_4.1.patch
ubuntu_buildfix_kernel_4.2.patch
- 4.2-fglrx-has_fpu.patch)
+ 4.2-fglrx-has_fpu.patch
+ 4.2-kolasa-fpu_save_init.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'601d9c756571dd79d26944e54827631e'
@@ -120,9 +122,8 @@ md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'880d5e59554cda382f74206c202942be'
'982451bcc1fa1ee3da53ffa481d65581'
'88832af8d6769aa51fa9b266a74394e0'
- 'ed7748a593d6b894269f8c7856b7ae50')
-
-
+ 'ed7748a593d6b894269f8c7856b7ae50'
+ 'dd51495a1d8f2d1042f04a783bf01e08')
build() {
@@ -308,8 +309,9 @@ package() {
patch -Np1 -i ../fglrx_gpl_symbol.patch
patch -Np1 -i ../ubuntu_buildfix_kernel_4.0.patch
patch -Np1 -i ../ubuntu_buildfix_kernel_4.1.patch
-# patch -Np1 -i ../ubuntu_buildfix_kernel_4.2.patch #two 4.2 patches left for testing purposes, use both simultaneously - V
-# patch -Np1 -i ../4.2-fglrx-has_fpu.patch
+ patch -Np1 -i ../ubuntu_buildfix_kernel_4.2.patch #three 4.2 patches left for testing purposes, use simultaneously - V
+ patch -Np1 -i ../4.2-fglrx-has_fpu.patch
+ patch -Np1 -i ../4.2-kolasa-fpu_save_init.patch
# Prepare modules source files
_archdir=x86_64