summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch14
-rw-r--r--PKGBUILD66
3 files changed, 55 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 859df51645c3..219ab6b51541 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jan 21 20:33:34 UTC 2018
+# Sun Feb 25 18:27:57 UTC 2018
pkgbase = catalyst-total
pkgdesc = AMD/ATI Catalyst drivers for linux. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
pkgver = 15.9
- pkgrel = 23
+ pkgrel = 24
url = http://www.amd.com
install = catalyst-total.install
arch = i686
@@ -11,7 +11,7 @@ pkgbase = catalyst-total
license = custom
depends = dkms
depends = linux>=3.0
- depends = linux<4.15
+ depends = linux<4.16
depends = linux-headers
depends = xorg-server>=1.7.0
depends = xorg-server<1.18.0
@@ -98,6 +98,7 @@ pkgbase = catalyst-total
source = 4.12-npfeiler-movsl_mask.patch
source = 4.13-npfeiler-wait_queue_t.patch
source = 4.14-npfeiler-task_struct-mm_segment_t.patch
+ source = 4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
md5sums = d2de2df6946b452c266a3c892e6e46ff
md5sums = af7fb8ee4fc96fd54c5b483e33dc71c4
md5sums = bdafe749e046bfddee2d1c5e90eabd83
@@ -133,6 +134,7 @@ pkgbase = catalyst-total
md5sums = cb25bc7fbb7d5cb1c07d2f3fa5fda826
md5sums = 0a725f40bc980d578cbed3e57a05b765
md5sums = 5ba3bf9f58aa63c1849b056cf23022c9
+ md5sums = 10af58c21e4e972115dda6dbd8279594
pkgname = catalyst-total
diff --git a/4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch b/4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
new file mode 100644
index 000000000000..1f9b7a4a777b
--- /dev/null
+++ b/4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
@@ -0,0 +1,14 @@
+--- archive_files/common/lib/modules/fglrx/build_mod/firegl_public.c 2015-12-18 19:47:41.000000000 +0100
++++ archive_filesb/common/lib/modules/fglrx/build_mod/firegl_public.c 2018-02-25 17:33:11.469309861 +0100
+@@ -2949,7 +2949,11 @@
+ static void kcl_flush_tlb_one(void *va)
+ {
+ unsigned long *addr = (unsigned long *)va;
++# if (LINUX_VERSION_CODE < KERNEL_VERSION(4,14,21))
+ __flush_tlb_one(*addr);
++# else
++ __flush_tlb_one_kernel(*addr);
++# endif
+ }
+
+ /** /brief Flush one page on all cpus
diff --git a/PKGBUILD b/PKGBUILD
index fdb2e9ed844c..5a25803f8c71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,19 +23,19 @@
# Contributor: Philip Muller @ Manjaro (4.4 kernel patch)
# Contributor: aslmaswd (acpi main script)
# Contributor: sling00 (4.10 kernel patch)
-# Contributor: npfeiler (libcl/opencl-icd-loader cleaning, 4.11, 4.12, 4.13 and 4.14 kernel patch)
+# Contributor: npfeiler (libcl/opencl-icd-loader cleaning, 4.11, 4.12, 4.13, 4.14 and 4.15.5 kernel patch))
pkgname=catalyst-total
pkgver=15.9
-pkgrel=23
+pkgrel=24
_amdver=15.201.1151
pkgdesc="AMD/ATI Catalyst drivers for linux. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"
arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
options=('staticlibs' 'libtool' '!strip' '!upx')
-depends=('dkms' 'linux>=3.0' 'linux<4.15' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa-noglvnd')
+depends=('dkms' 'linux>=3.0' 'linux<4.16' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.18.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa-noglvnd')
optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
@@ -104,7 +104,8 @@ source=(
4.12-arch-remove_clts.patch
4.12-npfeiler-movsl_mask.patch
4.13-npfeiler-wait_queue_t.patch
- 4.14-npfeiler-task_struct-mm_segment_t.patch)
+ 4.14-npfeiler-task_struct-mm_segment_t.patch
+ 4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch)
md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'af7fb8ee4fc96fd54c5b483e33dc71c4'
@@ -140,16 +141,44 @@ md5sums=('d2de2df6946b452c266a3c892e6e46ff'
'782769206ed12ded10c347be3e476729'
'cb25bc7fbb7d5cb1c07d2f3fa5fda826'
'0a725f40bc980d578cbed3e57a05b765'
- '5ba3bf9f58aa63c1849b056cf23022c9')
+ '5ba3bf9f58aa63c1849b056cf23022c9'
+ '10af58c21e4e972115dda6dbd8279594')
-
-build() {
+prepare() {
## Unpack archive
/bin/sh ./AMD-Catalyst-${pkgver}-Linux-installer-${_amdver}-x86.x86_64.run --extract archive_files
# mkdir common
# mv etc lib usr common
# mkdir archive_files
# mv arch common xpic xpic_64a archive_files
+
+ ## Patch
+ cd ${srcdir}/archive_files
+ patch -Np1 -i ../makefile_compat.patch
+ patch -Np1 -i ../lano1106_fglrx_intel_iommu.patch
+ patch -Np1 -i ../lano1106_kcl_agp_13_4.patch
+ patch -Np1 -i ../4.2-amd-from_crimson_15.11.patch
+ patch -Np1 -i ../4.3-kolasa-seq_printf.patch
+ patch -Np1 -i ../4.3-gentoo-mtrr.patch
+ patch -Np1 -i ../fglrx_gpl_symbol.patch
+ test "${CARCH}" = "i686" && patch -Np1 -i ../crimson_i686_xg.patch
+ patch -Np1 -i ../4.4-manjaro-xstate.patch
+ patch -Np1 -i ../grsec_arch.patch
+ patch -Np1 -i ../4.6-arch-get_user_pages-page_cache_release.patch
+ patch -Np1 -i ../makesh-dont-check-gcc-version.patch
+ patch -Np1 -i ../4.7-arch-cpu_has_pge-v2.patch
+ patch -Np1 -i ../4.9_over_4.6-arch-get_user_pages_remote.patch
+ patch -Np1 -i ../4.10-arch-sling00-virtual_address-acpi_get_table_with_size.patch
+ patch -Np1 -i ../4.11-npfeiler-signal_vmf.patch
+ patch -Np1 -i ../4.12-npfeiler-PUD_OFFSET.patch
+ patch -Np1 -i ../4.12-arch-remove_clts.patch
+ patch -Np1 -i ../4.12-npfeiler-movsl_mask.patch
+ patch -Np1 -i ../4.13-npfeiler-wait_queue_t.patch
+ patch -Np1 -i ../4.14-npfeiler-task_struct-mm_segment_t.patch
+ patch -Np1 -i ../4.14.21_4.15.5-npfeiler-flush_tlb_one_kernel.patch
+
+ cd ${srcdir}/archive_files/common
+ patch -Np2 -i ${srcdir}/arch-fglrx-authatieventsd_new.patch
}
package() {
@@ -257,7 +286,6 @@ package() {
cd ${srcdir}/archive_files/common
- patch -Np2 -i ${srcdir}/arch-fglrx-authatieventsd_new.patch
install -m644 etc/ati/* ${pkgdir}/etc/ati
chmod 755 ${pkgdir}/etc/ati/authatieventsd.sh
@@ -318,28 +346,6 @@ package() {
##catalyst-dkms section
cd ${srcdir}/archive_files
- patch -Np1 -i ../makefile_compat.patch
- patch -Np1 -i ../lano1106_fglrx_intel_iommu.patch
- patch -Np1 -i ../lano1106_kcl_agp_13_4.patch
- patch -Np1 -i ../4.2-amd-from_crimson_15.11.patch
- patch -Np1 -i ../4.3-kolasa-seq_printf.patch
- patch -Np1 -i ../4.3-gentoo-mtrr.patch
- patch -Np1 -i ../fglrx_gpl_symbol.patch
- test "${CARCH}" = "i686" && patch -Np1 -i ../crimson_i686_xg.patch
- patch -Np1 -i ../4.4-manjaro-xstate.patch
- patch -Np1 -i ../grsec_arch.patch
- patch -Np1 -i ../4.6-arch-get_user_pages-page_cache_release.patch
- patch -Np1 -i ../makesh-dont-check-gcc-version.patch
- patch -Np1 -i ../4.7-arch-cpu_has_pge-v2.patch
- patch -Np1 -i ../4.9_over_4.6-arch-get_user_pages_remote.patch
- patch -Np1 -i ../4.10-arch-sling00-virtual_address-acpi_get_table_with_size.patch
- patch -Np1 -i ../4.11-npfeiler-signal_vmf.patch
- patch -Np1 -i ../4.12-npfeiler-PUD_OFFSET.patch
- patch -Np1 -i ../4.12-arch-remove_clts.patch
- patch -Np1 -i ../4.12-npfeiler-movsl_mask.patch
- patch -Np1 -i ../4.13-npfeiler-wait_queue_t.patch
- patch -Np1 -i ../4.14-npfeiler-task_struct-mm_segment_t.patch
-
# Prepare modules source files
install -dm755 ${pkgdir}/usr/src/fglrx-${pkgver}/2.6.x
_archdir=x86_64