summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--4.7-cpu_has_pge-hd234k.patch71
-rw-r--r--PKGBUILD13
3 files changed, 84 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1cd060ad2ce..ab4ae619023b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = catalyst-total-hd234k
pkgdesc = AMD/ATI legacy drivers. catalyst-dkms+ catalyst-utils + lib32-catalyst-utils
pkgver = 13.1
- pkgrel = 36
+ pkgrel = 37
url = http://www.amd.com
install = catalyst-total-hd234k.install
arch = i686
@@ -9,7 +9,7 @@ pkgbase = catalyst-total-hd234k
license = custom
depends = dkms
depends = linux>=3.0
- depends = linux<4.7
+ depends = linux<4.8
depends = linux-headers
depends = xorg-server>=1.7.0
depends = xorg-server<1.13.0
@@ -87,6 +87,7 @@ pkgbase = catalyst-total-hd234k
source = dkms.conf
source = makesh-dont-check-gcc-version.patch
source = makesh-src_file.patch
+ source = 4.7-cpu_has_pge-hd234k.patch
md5sums = c07fd1332abe4c742a9a0d0e0d0a90de
md5sums = af7fb8ee4fc96fd54c5b483e33dc71c4
md5sums = bdafe749e046bfddee2d1c5e90eabd83
@@ -119,6 +120,7 @@ pkgbase = catalyst-total-hd234k
md5sums = 23d569abfdd7de433d76e003e4b3ccf9
md5sums = 10829e3b992b3e80a6e78c8e27748703
md5sums = 6cdc15206cc61e3de456416a9011db07
+ md5sums = 1e56499f8589d81a1a5eba98bad9912c
pkgname = catalyst-total-hd234k
diff --git a/4.7-cpu_has_pge-hd234k.patch b/4.7-cpu_has_pge-hd234k.patch
new file mode 100644
index 000000000000..18793250623a
--- /dev/null
+++ b/4.7-cpu_has_pge-hd234k.patch
@@ -0,0 +1,71 @@
+diff -uNr 16.8/common/lib/modules/fglrx/build_mod/firegl_public.c 16.8b/common/lib/modules/fglrx/build_mod/firegl_public.c
+--- 16.8/common/lib/modules/fglrx/build_mod/firegl_public.c 2013-01-15 22:33:27.000000000 +0100
++++ 16.8b/common/lib/modules/fglrx/build_mod/firegl_public.c 2016-08-17 19:25:56.443130600 +0200
+@@ -3904,8 +3904,11 @@
+ cr0 = read_cr0() | 0x40000000;
+ write_cr0(cr0);
+ wbinvd();
+-
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,7,0)
++ if (boot_cpu_has(X86_FEATURE_PGE))
++#else
+ if (cpu_has_pge)
++#endif
+ {
+ cr4 = read_cr4();
+ write_cr4(cr4 & ~X86_CR4_PGE);
+@@ -3919,7 +3922,11 @@
+ wbinvd();
+ __flush_tlb();
+ write_cr0(cr0 & 0xbfffffff);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,7,0)
++ if (boot_cpu_has(X86_FEATURE_PGE))
++#else
+ if (cpu_has_pge)
++#endif
+ {
+ write_cr4(cr4);
+ }
+@@ -3946,7 +3953,11 @@
+ write_cr0(cr0);
+ wbinvd();
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,7,0)
++ if (boot_cpu_has(X86_FEATURE_PGE))
++#else
+ if (cpu_has_pge)
++#endif
+ {
+ cr4 = read_cr4();
+ write_cr4(cr4 & ~X86_CR4_PGE);
+@@ -3959,7 +3970,11 @@
+ wbinvd();
+ __flush_tlb();
+ write_cr0(cr0 & 0xbfffffff);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,7,0)
++ if (boot_cpu_has(X86_FEATURE_PGE))
++#else
+ if (cpu_has_pge)
++#endif
+ {
+ write_cr4(cr4);
+ }
+diff -uNr 16.8/common/lib/modules/fglrx/build_mod/firegl_public.h 16.8b/common/lib/modules/fglrx/build_mod/firegl_public.h
+--- 16.8/common/lib/modules/fglrx/build_mod/firegl_public.h 2013-01-15 22:33:27.000000000 +0100
++++ 16.8b/common/lib/modules/fglrx/build_mod/firegl_public.h 2016-08-17 19:27:34.056235451 +0200
+@@ -590,9 +590,15 @@
+ #define cpu_has_pat test_bit(X86_FEATURE_PAT, (void *) &boot_cpu_data.x86_capability)
+ #endif
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4,7,0)
++#ifndef boot_cpu_has(X86_FEATURE_PGE)
++#define boot_cpu_has(X86_FEATURE_PGE) test_bit(X86_FEATURE_PGE, &boot_cpu_data.x86_capability)
++#endif
++#else
+ #ifndef cpu_has_pge
+ #define cpu_has_pge test_bit(X86_FEATURE_PGE, &boot_cpu_data.x86_capability)
+ #endif
++#endif
+
+ /* 2.6.29 defines pgprot_writecombine as a macro which resolves to a
+ * GPL-only function with the same name. So we always use our own
diff --git a/PKGBUILD b/PKGBUILD
index 262896bf18a8..92f486d91a6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,13 +27,13 @@
pkgname=catalyst-total-hd234k
pkgver=13.1
-pkgrel=36
+pkgrel=37
pkgdesc="AMD/ATI legacy drivers. catalyst-dkms+ catalyst-utils + lib32-catalyst-utils"
arch=('i686' 'x86_64')
url="http://www.amd.com"
license=('custom')
options=('staticlibs' 'libtool' '!strip' '!upx')
-depends=('dkms' 'linux>=3.0' 'linux<4.7' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.13.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4')
+depends=('dkms' 'linux>=3.0' 'linux<4.8' 'linux-headers' 'xorg-server>=1.7.0' 'xorg-server<1.13.0' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs' 'gcc>4.0.0' 'make' 'patch' 'libxinerama' 'mesa>=10.1.0-4')
optdepends=('qt4: to run ATi Catalyst Control Center (amdcccle)'
'libxxf86vm: to run ATi Catalyst Control Center (amdcccle)'
'opencl-headers: headers necessary for OpenCL development'
@@ -97,7 +97,9 @@ source=(
dkms.conf
makesh-dont-check-gcc-version.patch
- makesh-src_file.patch)
+ makesh-src_file.patch
+
+ 4.7-cpu_has_pge-hd234k.patch)
md5sums=('c07fd1332abe4c742a9a0d0e0d0a90de'
'af7fb8ee4fc96fd54c5b483e33dc71c4'
@@ -135,7 +137,9 @@ md5sums=('c07fd1332abe4c742a9a0d0e0d0a90de'
'23d569abfdd7de433d76e003e4b3ccf9'
'10829e3b992b3e80a6e78c8e27748703'
- '6cdc15206cc61e3de456416a9011db07')
+ '6cdc15206cc61e3de456416a9011db07'
+
+ '1e56499f8589d81a1a5eba98bad9912c')
build() {
@@ -316,6 +320,7 @@ package() {
patch -Np1 -i ../4.6-arch-get_user_pages-page_cache_release.patch
patch -Np1 -i ../makesh-dont-check-gcc-version.patch
patch -Np1 -i ../makesh-src_file.patch
+ patch -Np1 -i ../4.7-cpu_has_pge-hd234k.patch
# Prepare modules source files