summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD79
-rw-r--r--catppuccin-frappe-grub-theme-git.install15
-rw-r--r--catppuccin-grub-theme-git.install16
-rw-r--r--catppuccin-latte-grub-theme-git.install15
-rw-r--r--catppuccin-macchiato-grub-theme-git.install15
-rw-r--r--catppuccin-mocha-grub-theme-git.install15
7 files changed, 136 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2abbddc3d483..a4fb1a3f0dcd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,26 @@
pkgbase = catppuccin-grub-theme-git
- pkgdesc = Soothing pastel theme for GRUB2.
- pkgver = r24.3f62cd4
- pkgrel = 3
+ pkgdesc = Soothing pastel theme for GRUB2
+ pkgver = r25.4f6ac65
+ pkgrel = 1
url = https://github.com/catppuccin/grub
- install = catppuccin-grub-theme-git.install
arch = any
license = MIT
makedepends = git
- source = catppuccin-grub-theme-git::git+https://github.com/catppuccin/grub.git
+ source = git+https://github.com/catppuccin/grub.git
sha256sums = SKIP
-pkgname = catppuccin-grub-theme-git
+pkgname = catppuccin-frappe-grub-theme-git
+ pkgdesc = Soothing pastel theme for GRUB2 - frappe color scheme
+ install = catppuccin-frappe-grub-theme-git.install
+
+pkgname = catppuccin-latte-grub-theme-git
+ pkgdesc = Soothing pastel theme for GRUB2 - latte color scheme
+ install = catppuccin-latte-grub-theme-git.install
+
+pkgname = catppuccin-macchiato-grub-theme-git
+ pkgdesc = Soothing pastel theme for GRUB2 - macchiato color scheme
+ install = catppuccin-macchiato-grub-theme-git.install
+
+pkgname = catppuccin-mocha-grub-theme-git
+ pkgdesc = Soothing pastel theme for GRUB2 - mocha color scheme
+ install = catppuccin-mocha-grub-theme-git.install
diff --git a/PKGBUILD b/PKGBUILD
index f53d6b05ffd6..81b76ee77ba0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,63 @@
-# Maintainer: Tuhana GAYRETLÄ° <tuhana at tuta dot io>
-
-pkgname=catppuccin-grub-theme-git
-pkgver=r24.3f62cd4
-pkgrel=3
-pkgdesc="Soothing pastel theme for GRUB2."
-arch=("any")
-url="https://github.com/catppuccin/grub"
-license=("MIT")
-makedepends=("git")
-source=("$pkgname::git+https://github.com/catppuccin/grub.git")
-sha256sums=("SKIP")
-install="$pkgname.install"
-
-pkgver() {
- cd $pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+# Maintainer: Tuhana GAYRETLÄ° <tuhana at cok dot gay>
+# shellcheck disable=SC2034,SC2148,SC2164,SC2154,SC2128
+
+pkgname=(
+ catppuccin-frappe-grub-theme-git
+ catppuccin-latte-grub-theme-git
+ catppuccin-macchiato-grub-theme-git
+ catppuccin-mocha-grub-theme-git
+)
+pkgbase=catppuccin-grub-theme-git
+pkgver=r25.4f6ac65
+pkgrel=1
+pkgdesc='Soothing pastel theme for GRUB2'
+arch=(any)
+url='https://github.com/catppuccin/grub'
+license=(MIT)
+makedepends=(git)
+source=("git+$url.git")
+sha256sums=(SKIP)
+
+package_catppuccin-frappe-grub-theme-git() {
+ pkgdesc+=' - frappe color scheme'
+ install=$pkgname.install
+
+ cd "$srcdir/grub"
+
+ install -d "$pkgdir/usr/share/grub/themes"
+ cp -r "src/${pkgname%-git}" "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}
-package() {
- cd $pkgname
+package_catppuccin-latte-grub-theme-git() {
+ pkgdesc+=' - latte color scheme'
+ install=$pkgname.install
+
+ cd "$srcdir/grub"
- install -dm755 "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
+ install -d "$pkgdir/usr/share/grub/themes"
+ cp -r "src/${pkgname%-git}" "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
- install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
+}
+
+package_catppuccin-macchiato-grub-theme-git() {
+ pkgdesc+=' - macchiato color scheme'
+ install=$pkgname.install
- cp -r --no-preserve=ownership ${pkgname%-git}/* "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
+ cd "$srcdir/grub"
+
+ install -d "$pkgdir/usr/share/grub/themes"
+ cp -r "src/${pkgname%-git}" "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+}
+
+package_catppuccin-mocha-grub-theme-git() {
+ pkgdesc+=' - mocha color scheme'
+ install=$pkgname.install
+
+ cd "$srcdir/grub"
+
+ install -d "$pkgdir/usr/share/grub/themes"
+ cp -r "src/${pkgname%-git}" "$pkgdir/usr/share/grub/themes/${pkgname%-grub-theme-git}"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}
diff --git a/catppuccin-frappe-grub-theme-git.install b/catppuccin-frappe-grub-theme-git.install
new file mode 100644
index 000000000000..e3d1345574e2
--- /dev/null
+++ b/catppuccin-frappe-grub-theme-git.install
@@ -0,0 +1,15 @@
+. /usr/share/makepkg/util/message.sh
+colorize
+
+post_install() {
+ msg "Installed Catppuccin Frappe GRUB2 theme."
+ msg2 "To enable the theme, change 'GRUB_THEME' variable in '/etc/default/grub' file to"
+ msg2 "'/usr/share/grub/themes/catppuccin-frappe', uncomment it and update GRUB config with running"
+ msg2 "'grub-mkconfig -o /boot/grub/grub.cfg' as root."
+}
+
+post_remove() {
+ warning "Uninstalled Catppuccin Frappe GRUB2 theme."
+ msg2 "To disable the theme, comment 'GRUB_THEME' variable in '/etc/default/grub' file"
+ msg2 "and update GRUB config with running 'grub-mkconfig -o /boot/grub/grub.cfg' as root."
+}
diff --git a/catppuccin-grub-theme-git.install b/catppuccin-grub-theme-git.install
deleted file mode 100644
index 6b6ad2ec32c3..000000000000
--- a/catppuccin-grub-theme-git.install
+++ /dev/null
@@ -1,16 +0,0 @@
-. /usr/share/makepkg/util/message.sh
-colorize
-
-post_install() {
- sed -ie 's,.*GRUB_THEME=.*,GRUB_THEME="/usr/share/grub/themes/catppuccin/theme.txt",' /etc/default/grub
-
- msg "Installed Catppuccin GRUB2 theme."
- msg2 "Run 'grub-mkconfig -o /boot/grub/grub.cfg' as root to apply the theme."
-}
-
-post_remove() {
- sed -ie 's,.*GRUB_THEME=.*,#GRUB_THEME="/path/to/gfxtheme",' /etc/default/grub
-
- warning "Uninstalled Catppuccin GRUB2 theme."
- msg2 "Run 'grub-mkconfig -o /boot/grub/grub.cfg' as root to disable the theme."
-}
diff --git a/catppuccin-latte-grub-theme-git.install b/catppuccin-latte-grub-theme-git.install
new file mode 100644
index 000000000000..bb9d9e3cf9c9
--- /dev/null
+++ b/catppuccin-latte-grub-theme-git.install
@@ -0,0 +1,15 @@
+. /usr/share/makepkg/util/message.sh
+colorize
+
+post_install() {
+ msg "Installed Catppuccin Latte GRUB2 theme."
+ msg2 "To enable the theme, change 'GRUB_THEME' variable in '/etc/default/grub' file to"
+ msg2 "'/usr/share/grub/themes/catppuccin-latte', uncomment it and update GRUB config with running"
+ msg2 "'grub-mkconfig -o /boot/grub/grub.cfg' as root."
+}
+
+post_remove() {
+ warning "Uninstalled Catppuccin Latte GRUB2 theme."
+ msg2 "To disable the theme, comment 'GRUB_THEME' variable in '/etc/default/grub' file"
+ msg2 "and update GRUB config with running 'grub-mkconfig -o /boot/grub/grub.cfg' as root."
+}
diff --git a/catppuccin-macchiato-grub-theme-git.install b/catppuccin-macchiato-grub-theme-git.install
new file mode 100644
index 000000000000..73e6d4ed9bf7
--- /dev/null
+++ b/catppuccin-macchiato-grub-theme-git.install
@@ -0,0 +1,15 @@
+. /usr/share/makepkg/util/message.sh
+colorize
+
+post_install() {
+ msg "Installed Catppuccin Macchiato GRUB2 theme."
+ msg2 "To enable the theme, change 'GRUB_THEME' variable in '/etc/default/grub' file to"
+ msg2 "'/usr/share/grub/themes/catppuccin-macchiato', uncomment it and update GRUB config with running"
+ msg2 "'grub-mkconfig -o /boot/grub/grub.cfg' as root."
+}
+
+post_remove() {
+ warning "Uninstalled Catppuccin Macchiato GRUB2 theme."
+ msg2 "To disable the theme, comment 'GRUB_THEME' variable in '/etc/default/grub' file"
+ msg2 "and update GRUB config with running 'grub-mkconfig -o /boot/grub/grub.cfg' as root."
+}
diff --git a/catppuccin-mocha-grub-theme-git.install b/catppuccin-mocha-grub-theme-git.install
new file mode 100644
index 000000000000..50405197413c
--- /dev/null
+++ b/catppuccin-mocha-grub-theme-git.install
@@ -0,0 +1,15 @@
+. /usr/share/makepkg/util/message.sh
+colorize
+
+post_install() {
+ msg "Installed Catppuccin Mocha GRUB2 theme."
+ msg2 "To enable the theme, change 'GRUB_THEME' variable in '/etc/default/grub' file to"
+ msg2 "'/usr/share/grub/themes/catppuccin-mocha', uncomment it and update GRUB config with running"
+ msg2 "'grub-mkconfig -o /boot/grub/grub.cfg' as root."
+}
+
+post_remove() {
+ warning "Uninstalled Catppuccin Mocha GRUB2 theme."
+ msg2 "To disable the theme, comment 'GRUB_THEME' variable in '/etc/default/grub' file"
+ msg2 "and update GRUB config with running 'grub-mkconfig -o /boot/grub/grub.cfg' as root."
+}