summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD55
-rw-r--r--cavestory+.desktop7
-rw-r--r--cavestory+.pngbin0 -> 2479 bytes
-rw-r--r--cavestory+.sh3
5 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fd0af54ef9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = cavestory+-hb
+ pkgdesc = A platformer adventure game set in a cave (humble bundle version)
+ pkgver = 1355961600
+ pkgrel = 1
+ url = http://nicalis.com/games.php?game=cavestory
+ arch = x86_64
+ arch = i686
+ license = custom: comercial
+ depends = sdl
+ depends = glu
+ provides = cavestory+
+ conflicts = cavestory+
+ options = !strip
+ source = hib://cave_story_plus-linux-r100.tar.bz2
+ source = cavestory+.sh
+ source = cavestory+.desktop
+ source = cavestory+.png
+ sha256sums = 3eea507acdcf543393e9215d1d66b61a00d37a4e451294ab241a121fd4185bc8
+ sha256sums = 21af1b6df4bb8e599092201b102b5aae52f2c62789bcdd3e41c4d77fc7a8c7a0
+ sha256sums = 5d2d9d0ef17b2a798c89c12dafa4539a4275b7c703d7b3e3f2682af8608fcff7
+ sha256sums = afed0ff2ec41d2b0272b5ce50f7497c7a43b3149a21a9444535d883f8525e816
+
+pkgname = cavestory+-hb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..236d5b5182c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributors: Claudio Kozicky, Yann Kaiser, mib1982
+
+pkgname=cavestory+-hb
+pkgver=1355961600
+pkgrel=1
+pkgdesc="A platformer adventure game set in a cave (humble bundle version)"
+arch=('x86_64' 'i686')
+url="http://nicalis.com/games.php?game=cavestory"
+license=('custom: comercial')
+depends=('sdl' 'glu')
+conflicts=('cavestory+')
+provides=('cavestory+')
+options=('!strip')
+source=("hib://cave_story_plus-linux-r100.tar.bz2"
+ "cavestory+.sh"
+ "cavestory+.desktop"
+ "cavestory+.png")
+sha256sums=('3eea507acdcf543393e9215d1d66b61a00d37a4e451294ab241a121fd4185bc8'
+ '21af1b6df4bb8e599092201b102b5aae52f2c62789bcdd3e41c4d77fc7a8c7a0'
+ '5d2d9d0ef17b2a798c89c12dafa4539a4275b7c703d7b3e3f2682af8608fcff7'
+ 'afed0ff2ec41d2b0272b5ce50f7497c7a43b3149a21a9444535d883f8525e816')
+PKGEXT=.pkg.tar
+
+# You need to download the Humble Bundle file manually to this directory ($PWD)
+# or you can configure DLAGENTS in makepkg.conf to auto-download.
+#
+# For example, hib-dlagent (https://aur.archlinux.org/packages/hib-dlagent/)
+# can be used to download files. Add something like this in your makepkg.conf
+# (you need to tweak the options to your needs):
+# DLAGENTS+=('hib::/usr/bin/hib-dlagent -k $KEY -u $USER -p $PASS -o %o %u')
+#
+# The following is just a fallback to the above to notify the user:
+DLAGENTS+=('hib::/usr/bin/awk BEGIN{print"Please\ download\ the\ file\ \\""\ substr("%u",7)\ "\\"\ manually\\nor\ setup\ a\ hib://\ DLAGENT\ in\ makepkg.conf!\ Read\ this\ PKGBUILD\ for\ more\ information.";exit\ 1}')
+
+package() {
+ # executable
+ [ "$CARCH" == "x86_64" ] && install -Dm0755 CaveStoryPlus/CaveStory+_64 \
+ "$pkgdir"/opt/CaveStoryPlus/CaveStory+
+ [ "$CARCH" == "i686" ] && install -Dm0755 CaveStoryPlus/CaveStory+ \
+ "$pkgdir"/opt/CaveStoryPlus/CaveStory+
+
+ # data
+ find CaveStoryPlus -name icon.bmp -prune \
+ -o -name "CaveStory+*" -prune -o -name "lib*" -prune \
+ -o -type f -exec install -Dm0644 {} "$pkgdir"/opt/{} \;
+
+ # launcher
+ install -Dm0755 cavestory+.sh "$pkgdir"/usr/bin/cavestory+
+
+ # .desktop integration
+ install -Dm0644 CaveStoryPlus/data/icon.bmp "$pkgdir"/usr/share/pixmaps/cavestory+.bmp
+ install -Dm0644 cavestory+.png "$pkgdir"/usr/share/pixmaps/cavestory+.png
+ install -Dm0644 cavestory+.desktop "$pkgdir"/usr/share/applications/cavestory+.desktop
+}
diff --git a/cavestory+.desktop b/cavestory+.desktop
new file mode 100644
index 000000000000..bec3c7adea6d
--- /dev/null
+++ b/cavestory+.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Cave Story+
+Comment=A platform-adventure game set in a cave.
+Icon=cavestory+
+Exec=cavestory+
+Categories=Game;AdventureGame;
diff --git a/cavestory+.png b/cavestory+.png
new file mode 100644
index 000000000000..8a799e1351ba
--- /dev/null
+++ b/cavestory+.png
Binary files differ
diff --git a/cavestory+.sh b/cavestory+.sh
new file mode 100644
index 000000000000..528a4f99075b
--- /dev/null
+++ b/cavestory+.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd /opt/CaveStoryPlus && exec ./CaveStory+