summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..006feb6e80f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cba
+ pkgdesc = Continuous beam analysis - calculates member forces and support reactions of a continuous beam
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = http://cbeam.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = wxgtk
+ source = http://downloads.sourceforge.net/sourceforge/cbeam/cba-0.3.6-linux.tar.gz
+ md5sums = ef9d12b03918e8b75fdc3b1525412b5c
+
+pkgname = cba
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd6d21a54f4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: mickele
+
+pkgname=cba
+pkgver=0.3.6
+pkgrel=1
+pkgdesc='Continuous beam analysis - calculates member forces and support reactions of a continuous beam'
+arch=('i686' 'x86_64')
+url='http://cbeam.sourceforge.net/'
+license=('GPL3')
+depends=('wxgtk')
+makedepends=()
+options=()
+install=
+source=("http://downloads.sourceforge.net/sourceforge/cbeam/cba-${pkgver}-linux.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ sed -e "s|-lstdc++| -lstdc++ -lm|" -i src/gui/Makefile
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ mkdir -p "${pkgdir}/usr/bin"
+
+ make DESTDIR="${pkgdir}" install
+}
+
+md5sums=('ef9d12b03918e8b75fdc3b1525412b5c')