summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD29
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a29e1526128c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Jan 26 19:00:11 UTC 2017
+pkgbase = cbang-git
+ pkgdesc = a library of cross-platform C++ utilities
+ pkgver = 1.0.1.r229.g3335df9
+ pkgrel = 1
+ url = https://github.com/CauldronDevelopmentLLC/cbang.git
+ arch = any
+ license = GNU GPL v2.1
+ depends = scons
+ depends = boost-libs
+ depends = openssl
+ depends = libmariadbclient
+ source = git+https://github.com/CauldronDevelopmentLLC/cbang
+ md5sums = SKIP
+
+pkgname = cbang-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9f4f572f25a0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.tar.gz
+*.tar.xz
+cbang/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75e534f62d85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=cbang-git
+pkgver=1.0.1.r229.g3335df9
+pkgrel=1
+pkgdesc="a library of cross-platform C++ utilities"
+arch=('any')
+url="https://github.com/CauldronDevelopmentLLC/cbang.git"
+license=('GNU GPL v2.1')
+depends=('scons'
+ 'boost-libs'
+ 'openssl'
+ 'libmariadbclient')
+source=("git+https://github.com/CauldronDevelopmentLLC/cbang")
+md5sums=('SKIP')
+
+pkgver() {
+ cd cbang
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd cbang
+ scons
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr
+ cp -a ${srcdir}/cbang/lib ${pkgdir}/usr/
+}
+