summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--0002_include_cstdint.patch11
-rw-r--r--PKGBUILD9
4 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d624ce9b327e..2ecbc141d322 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cbang-git
pkgdesc = A library of cross-platform C++ utilities
- pkgver = r1485.ac8bbdd5
+ pkgver = r1486.83595737
pkgrel = 1
url = https://github.com/CauldronDevelopmentLLC/cbang
arch = x86_64
@@ -22,7 +22,9 @@ pkgbase = cbang-git
conflicts = cbang
source = git+https://github.com/CauldronDevelopmentLLC/cbang.git
source = 0001_v8_sandbox_enable.patch
+ source = 0002_include_cstdint.patch
sha256sums = SKIP
sha256sums = 75eff0bcd04293990f8dfb0771562356ccac2a7f40a06df0c0ba515fcdf4126a
+ sha256sums = 0137c007c7596cbd9d9f7194cd6e1aaf11819489c815c57b29b9873523d25cd7
pkgname = cbang-git
diff --git a/.gitignore b/.gitignore
index 3e05f0deb69e..7735b4612827 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,4 @@
!PKGBUILD
!.SRCINFO
!.gitignore
-!.patch
+!*.patch
diff --git a/0002_include_cstdint.patch b/0002_include_cstdint.patch
new file mode 100644
index 000000000000..58cf1ec48887
--- /dev/null
+++ b/0002_include_cstdint.patch
@@ -0,0 +1,11 @@
+diff -ruN a/src/cbang/openssl/BigNum.h b/src/cbang/openssl/BigNum.h
+--- a/src/cbang/openssl/BigNum.h 2023-05-08 16:23:34.979999959 -0400
++++ b/src/cbang/openssl/BigNum.h 2023-05-08 16:24:14.376666623 -0400
+@@ -32,6 +32,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <string>
+
+ typedef struct bignum_st BIGNUM;
diff --git a/PKGBUILD b/PKGBUILD
index f20be91141ce..76181143cd62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: greyltc
pkgname=cbang-git
-pkgver=r1485.ac8bbdd5
+pkgver=r1486.83595737
pkgrel=1
pkgdesc="A library of cross-platform C++ utilities"
arch=('x86_64')
@@ -32,9 +32,11 @@ optdepends=(
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+https://github.com/CauldronDevelopmentLLC/cbang.git"
- "0001_v8_sandbox_enable.patch")
+ "0001_v8_sandbox_enable.patch"
+ "0002_include_cstdint.patch")
sha256sums=('SKIP'
- '75eff0bcd04293990f8dfb0771562356ccac2a7f40a06df0c0ba515fcdf4126a')
+ '75eff0bcd04293990f8dfb0771562356ccac2a7f40a06df0c0ba515fcdf4126a'
+ '0137c007c7596cbd9d9f7194cd6e1aaf11819489c815c57b29b9873523d25cd7')
pkgver() {
cd "${pkgname%-git}"
@@ -44,6 +46,7 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
patch -p1 -i "../0001_v8_sandbox_enable.patch"
+ patch -p1 -i "../0002_include_cstdint.patch"
}
build() {