summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04dfdc057af2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cbonsai-git
+ pkgdesc = A bonsai tree generator, written in C using ncurses
+ pkgver = r40.afb6878
+ pkgrel = 1
+ url = https://gitlab.com/jallbrit/cbonsai
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gcc
+ provides = cbonsai
+ source = cbonsai::git+https://gitlab.com/jallbrit/cbonsai.git
+ md5sums = SKIP
+
+pkgname = cbonsai-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5aa8e758b302
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Nicholas Boyd Isacsson <nicholas@isacsson.se>
+
+_pkgname='cbonsai'
+pkgname="${_pkgname}-git"
+pkgver=r40.afb6878
+pkgrel=1
+pkgdesc='A bonsai tree generator, written in C using ncurses'
+arch=('any')
+url="https://gitlab.com/jallbrit/${_pkgname}"
+license=('GPL3')
+depends=('gcc')
+makedepends=('git')
+provides=('cbonsai')
+source=("${_pkgname}::git+${url}.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ gcc cbonsai.c -Wall -Wpedantic -l panel -l ncurses -o cbonsai
+ install -vDm 755 cbonsai -t "${pkgdir}/usr/bin/"
+}