summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD27
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19db9a9de33b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ccal
+ pkgdesc = A console program which writes a calendar together with Chinese calendar to standard output.
+ pkgver = 2.5.3
+ pkgrel = 2
+ url = http://ccal.chinesebay.com/ccal/ccal.htm
+ arch = i686
+ arch = x86_64
+ arch = sh4
+ license = GPL
+ makedepends = gcc
+ depends = gcc-libs
+ depends = bash
+ source = http://ccal.chinesebay.com/ccal/ccal-2.5.3.tar.gz
+ sha1sums = b44d73804ef3ba9129ae196887509f99b508401c
+
+pkgname = ccal
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5c8e21e44598
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+## Ignore everything
+*.zip
+*.xz
+*.gz
+*.bz2
+*.7z
+src/*
+pkg/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23b797251ee6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Daniel YC Lin <dlin at gmail>
+# Contributor: sssslang <xofyarg at gmail>
+# Contributor: kumkee <kumkee at gmail>
+pkgname=ccal
+pkgver=2.5.3
+pkgrel=2
+pkgdesc="A console program which writes a calendar together with Chinese calendar to standard output."
+arch=('i686' 'x86_64' sh4)
+url="http://ccal.chinesebay.com/ccal/ccal.htm"
+license="GPL"
+depends=('gcc-libs' 'bash')
+makedepends=('gcc')
+source=(http://ccal.chinesebay.com/ccal/$pkgname-$pkgver.tar.gz)
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ mkdir -p $pkgdir/{usr/bin,usr/share/man/man1}
+ install -c ccal $pkgdir/usr/bin
+ install -c ccalpdf $pkgdir/usr/bin
+ install -c -m 0644 ccal.1 $pkgdir/usr/share/man/man1
+ install -c -m 0644 ccalpdf.1 $pkgdir/usr/share/man/man1
+}
+sha1sums=('b44d73804ef3ba9129ae196887509f99b508401c')