summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef9523e90994..50246adb692b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = cccc
arch = x86_64
license = GPL
depends = gcc-libs
- source = http://downloads.sourceforge.net/sourceforge/cccc/cccc-3.1.4.tar.gz
+ source = https://downloads.sourceforge.net/sourceforge/cccc/cccc-3.1.4.tar.gz
source = gcc47.patch
md5sums = 7bd3ad868913a0beab2fde931737f928
md5sums = e1d2cb39fcac3f3c14eaff4f1e8f2825
diff --git a/PKGBUILD b/PKGBUILD
index 61c2c6d0f939..3fc21c96b7e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ arch=('i686' 'x86_64')
url="http://cccc.sourceforge.net/"
depends=('gcc-libs')
license=('GPL')
-source=(http://downloads.sourceforge.net/sourceforge/cccc/$pkgname-$pkgver.tar.gz
+source=(https://downloads.sourceforge.net/sourceforge/cccc/$pkgname-$pkgver.tar.gz
gcc47.patch)
md5sums=('7bd3ad868913a0beab2fde931737f928'
'e1d2cb39fcac3f3c14eaff4f1e8f2825')
@@ -17,12 +17,12 @@ build() {
sed -e 's/su root -c "make -f install.mak"/make -f install.mak/' \
-e 's/all : pccts cccc test install/all : pccts cccc test/' \
- -i makefile || return 1
+ -i makefile
sed -e 's:/usr/local/bin:'$pkgdir'/usr/bin:' \
- -e 's/\$(MKDIR)/\$(MKDIR) -p/' -i install/install.mak || return 1
+ -e 's/\$(MKDIR)/\$(MKDIR) -p/' -i install/install.mak
patch -p1 < ../gcc47.patch
- make -j 1 || return 1
+ make -j 1
}
package() {