summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e56e9c6d34ac..87c9897e5ada 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cdo
pkgdesc = Command line tool manipulate and analyse Climate model Data. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 400 operators available.
- pkgver = 1.9.3
+ pkgver = 1.9.4
pkgrel = 0
url = https://code.zmaw.de/projects/cdo
arch = i686
@@ -26,8 +26,8 @@ pkgbase = cdo
depends = curl
depends = jasper
depends = magics++
- source = https://code.zmaw.de/attachments/download/16435/cdo-1.9.3.tar.gz
- md5sums = 13ae222164413dbd53532b03b072def5
+ source = https://code.zmaw.de/attachments/download/17374/cdo-1.9.4.tar.gz
+ md5sums = 377c9e5aa7d8cbcb4a6c558abb2eb053
pkgname = cdo
diff --git a/PKGBUILD b/PKGBUILD
index d382b3b75fe9..1bfd4e83f517 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Ralf Mueller <stark.dreamdetective@gmail.com>
# Contributor: Ralf Mueller <stark.dreamdetective@gmail.com>
pkgname=cdo
-pkgver=1.9.3
-fileID=16435
+pkgver=1.9.4
+fileID=17374
pkgrel=0
pkgdesc="Command line tool manipulate and analyse Climate model Data. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 400 operators available."
url="https://code.zmaw.de/projects/cdo"
@@ -16,7 +16,7 @@ arch=(i686 x86_64)
backup=()
install=
source=(https://code.zmaw.de/attachments/download/${fileID}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('13ae222164413dbd53532b03b072def5')
+md5sums=('377c9e5aa7d8cbcb4a6c558abb2eb053')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -31,8 +31,8 @@ build() {
--with-eccodes=/usr \
--with-magics=/usr \
--with-libxml2=/usr \
- CFLAGS="-g -O3 -std=gnu99 -Wall -fopenmp -march=native " \
- CXXFLAGS="-g -O3 -std=c++11 -Wall -fopenmp -march=native " \
+ CFLAGS="-g -O3 -std=gnu99 -Wall -fopenmp -march=native -ftree-vectorize -mavx2" \
+ CXXFLAGS="-g -O3 -std=c++11 -Wall -fopenmp -march=native -ftree-vectorize -mavx2" \
LIBS="-ljasper -lpng -lopenjpeg" \
CPPFLAGS="-I/usr/include/magics -I/usr/include/libxml2"