summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f831b9fe096b..32dae8d14cc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cdo
pkgdesc = Command line tool manipulate and analyse Climate model Data. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 400 operators available.
- pkgver = 1.8.0
+ pkgver = 1.8.1
pkgrel = 0
url = https://code.zmaw.de/projects/cdo
arch = i686
@@ -10,7 +10,7 @@ pkgbase = cdo
makedepends = hdf5
makedepends = proj
makedepends = szip
- makedepends = grib_api
+ makedepends = eccodes
makedepends = udunits
makedepends = fftw
makedepends = curl
@@ -20,14 +20,14 @@ pkgbase = cdo
depends = hdf5
depends = proj
depends = szip
- depends = grib_api
+ depends = eccodes
depends = udunits
depends = fftw
depends = curl
depends = jasper
depends = magics++
- source = https://code.zmaw.de/attachments/download/13772/cdo-1.8.0.tar.gz
- md5sums = 42d4990a7c03159bc74335035273a59d
+ source = https://code.zmaw.de/attachments/download/14271/cdo-1.8.1.tar.gz
+ md5sums = 54498438de788f245d47499efad7966c
pkgname = cdo
diff --git a/PKGBUILD b/PKGBUILD
index ea15f7ed988e..c58bbb4887c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Ralf Mueller <stark.dreamdetective@gmail.com>
# Contributor: Ralf Mueller <stark.dreamdetective@gmail.com>
pkgname=cdo
-pkgver=1.8.0
-fileID=13772
+pkgver=1.8.1
+fileID=14271
pkgrel=0
pkgdesc="Command line tool manipulate and analyse Climate model Data. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 400 operators available."
url="https://code.zmaw.de/projects/cdo"
license=('GPLv2')
-depends=('netcdf' 'hdf5' 'proj' 'szip' 'grib_api' 'udunits' 'fftw' 'curl' 'jasper' 'magics++')
-makedepends=('netcdf' 'hdf5' 'proj' 'szip' 'grib_api' 'udunits' 'fftw' 'curl' 'jasper' 'magics++')
+depends=('netcdf' 'hdf5' 'proj' 'szip' 'eccodes' 'udunits' 'fftw' 'curl' 'jasper' 'magics++')
+makedepends=('netcdf' 'hdf5' 'proj' 'szip' 'eccodes' 'udunits' 'fftw' 'curl' 'jasper' 'magics++')
provides=()
conflicts=()
replaces=()
@@ -16,7 +16,7 @@ arch=(i686 x86_64)
backup=()
install=
source=(https://code.zmaw.de/attachments/download/${fileID}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('42d4990a7c03159bc74335035273a59d')
+md5sums=('54498438de788f245d47499efad7966c')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -32,16 +32,10 @@ build() {
--with-magics=/usr \
--with-libxml2=/usr \
CFLAGS="-g -O3 -std=gnu99 -Wall -fopenmp -march=native " \
- LIBS="-lhdf5 -ljasper -lpng -lopenjpeg" \
+ LIBS="-leccodes -lhdf5 -ljasper -lpng -lopenjpeg" \
CPPFLAGS="-I/usr/include/magics -I/usr/include/libxml2"
- make -j12 || return
-
-# ./configure --prefix=/usr --with-netcdf=/usr --with-udunits2=/usr
-# --with-hdf5=/usr --with-szlib=/usr --with-grib_api=/usr --with-magics=/usr
-# CFLAGS="-g -O3 -Wall -fopenmp -march=native $(pkg-config magics --cflags)
-# -std=gnu99" --with-libxml2 LIBS='-lpng -lopenjpeg -lstdc++'
-#
+ make -j12 || return
}
package() {