summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62b4cbdb155e..c48b7637dda1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cdo
pkgdesc = Command line tool manipulate and analyse Climate model Data. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 400 operators available.
- pkgver = 1.9.10
- pkgrel = 1
+ pkgver = 2.0.0
+ pkgrel = 0
url = https://code.zmaw.de/projects/cdo
arch = i686
arch = x86_64
@@ -26,8 +26,7 @@ pkgbase = cdo
depends = curl
depends = jasper
depends = magics++
- source = https://code.zmaw.de/attachments/download/24638/cdo-1.9.10.tar.gz
- sha256sums = cc39c89bbb481d7b3945a06c56a8492047235f46ac363c4f0d980fccdde6677e
+ source = https://code.zmaw.de/attachments/download/26370/cdo-2.0.0.tar.gz
+ sha256sums = 6bca54e9d69d8c1f072f1996547b7347a65743d15ba751967e9bb16e0ff7a843
pkgname = cdo
-
diff --git a/PKGBUILD b/PKGBUILD
index 5bc6c8bc91df..a4660a15a74c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Ralf Mueller <stark.dreamdetective@gmail.com>
# Contributor: Ralf Mueller <stark.dreamdetective@gmail.com>
pkgname=cdo
-pkgver=1.9.10
-fileID=24638
-pkgrel=1
+pkgver=2.0.0
+fileID=26370
+pkgrel=0
pkgdesc="Command line tool manipulate and analyse Climate model Data. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 400 operators available."
url="https://code.zmaw.de/projects/cdo"
license=('GPLv2')
@@ -16,7 +16,7 @@ arch=(i686 x86_64)
backup=()
install=
source=(https://code.zmaw.de/attachments/download/${fileID}/${pkgname}-${pkgver}.tar.gz)
-sha256sums=('cc39c89bbb481d7b3945a06c56a8492047235f46ac363c4f0d980fccdde6677e')
+sha256sums=('6bca54e9d69d8c1f072f1996547b7347a65743d15ba751967e9bb16e0ff7a843')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -31,8 +31,8 @@ build() {
--with-eccodes=/usr \
--with-magics=/usr \
--with-libxml2=/usr \
- CFLAGS="-g -O3 -Wall -fopenmp -march=native -ftree-vectorize -mavx2" \
- CXXFLAGS="-g -O3 -Wall -fopenmp -march=native -ftree-vectorize -mavx2"
+ CFLAGS="-g -O3 -Wall -fopenmp" \
+ CXXFLAGS="-g -O3 -Wall -fopenmp"
make -j12 || return
}