summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3f925c4ed9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = celestia-addon-atlantis_2
+ pkgdesc = Celestia addon: Spacecraft: Earth Orbit: Atlantis with Flight Deck
+ pkgver = 2.0
+ pkgrel = 1
+ url = http://www.celestiamotherlode.net/catalog/show_addon_details.php?addon_id=861
+ arch = any
+ license = Creative Commons, some rights reserved
+ makedepends = unzip
+ depends = celestia
+ conflicts = celestia-addon-atlantis-2
+ source = http://www.celestiamotherlode.net/creators/elchristou/EC_Atlantis_FD.zip
+ md5sums = 08e74b20c0969c998ce230be8a0061a2
+
+pkgname = celestia-addon-atlantis_2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21152755094f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=celestia-addon-atlantis_2
+pkgver=2.0
+pkgrel=1
+pkgdesc="Celestia addon: Spacecraft: Earth Orbit: Atlantis with Flight Deck"
+arch=('any')
+url="http://www.celestiamotherlode.net/catalog/show_addon_details.php?addon_id=861"
+license=('Creative Commons, some rights reserved')
+depends=('celestia')
+makedepends=('unzip')
+conflicts=('celestia-addon-atlantis-2')
+source=("http://www.celestiamotherlode.net/creators/elchristou/EC_Atlantis_FD.zip")
+
+package() {
+ mkdir --parents "$pkgdir/usr/share/celestia/extras/"
+ cp --recursive "$srcdir/EC_Atlantis_FD" "$pkgdir/usr/share/celestia/extras/"
+ # Fix file permission problem:
+ chmod 644 "$pkgdir/usr/share/celestia/extras/EC_Atlantis_FD/Atlantis.ssc"
+}
+
+md5sums=('08e74b20c0969c998ce230be8a0061a2')