summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a4b3e09fb62..bd4b16ec512d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,28 @@
+# Generated by mksrcinfo v8
+# Wed May 3 20:27:09 UTC 2017
pkgbase = cellprofiler-analyst-git
pkgdesc = Analysis software for cellular images
- pkgver = 2.0.4.r464.g3a8646d
+ pkgver = 2.2.0.r0.gf45d68a
pkgrel = 1
url = http://www.cellprofiler.org/
arch = i686
arch = x86_64
license = GPLv2
- depends = wxpython2.8
+ depends = wxpython
+ depends = python2-pytz
depends = python2-numpy
depends = python2-scipy
depends = python2-matplotlib
depends = python2-imaging
- depends = python2-pytz
+ depends = python2-scikit-learn
+ depends = python2-pandas
depends = python2-verlib
+ depends = python2-seaborn
depends = python2-javabridge
depends = python2-bioformats
optdepends = cellprofiler: prepare data for CPA
provides = cellprofiler-analyst
- source = cellprofiler-analyst-git::git+https://github.com/CellProfiler/CellProfiler-Analyst#commit=3a8646d
+ source = cellprofiler-analyst-git::git+https://github.com/CellProfiler/CellProfiler-Analyst#tag=2.2.0
source = cellprofiler-analyst.desktop
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 48a65e6e56ac..0b76498b48f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,29 @@
# Maintainer: Eugene Dvoretsky <radioxoma at gmail>
pkgname=cellprofiler-analyst-git
-pkgver=2.0.4.r464.g3a8646d
+pkgver=2.2.0.r0.gf45d68a
pkgrel=1
pkgdesc="Analysis software for cellular images"
arch=('i686' 'x86_64')
url="http://www.cellprofiler.org/"
license=('GPLv2')
depends=(
- 'wxpython2.8'
+ 'wxpython'
+ 'python2-pytz'
'python2-numpy'
'python2-scipy'
'python2-matplotlib'
'python2-imaging'
- 'python2-pytz'
+ # 'python2-mock'
+ 'python2-scikit-learn'
+ 'python2-pandas'
'python2-verlib'
+ 'python2-seaborn'
'python2-javabridge'
'python2-bioformats')
optdepends=('cellprofiler: prepare data for CPA')
provides=('cellprofiler-analyst')
-source=("$pkgname::git+https://github.com/CellProfiler/CellProfiler-Analyst#commit=3a8646d"
+source=("$pkgname::git+https://github.com/CellProfiler/CellProfiler-Analyst#tag=2.2.0"
"cellprofiler-analyst.desktop")
sha256sums=('SKIP'
'SKIP')
@@ -38,21 +42,13 @@ prepare() {
}
build() {
- cd "$srcdir/$pkgname"
- # force selection of wxpython2.8 (xargs helps handle spaces)
- find . -name '*.py' -print0 | xargs -0 sed -i -e "s/^\(.*\)import wx$/\1import wxversion\n\1wxversion.select(\"2.8\")\n\1import wx/g"
-
- # python2 setup.py build # Unusable build system (only for Mac now)
- python2 -m compileall cpa
+ cd "$srcdir/$pkgname"
+ # python2 setup.py build # Unusable build system (only for Mac now)
+ python2 -m compileall cpa
}
-# check() {
-# cd "$srcdir/CellProfiler-Analyst"
-# python2 setup.py test # Only for Mac now
-# }
-
package() {
- # python2 setup.py install --root="$pkgdir"/ --optimize=1 # Only for Mac now
+ # python2 setup.py install --root="$pkgdir" --optimize=1 # Unusable build system (only for Mac now)
pydir=`python2 -c "from distutils.sysconfig import get_python_lib; print get_python_lib()"`
mkdir -p "$pkgdir/$pydir"