summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--fullscreen-f11.patch22
3 files changed, 5 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab3d7aabbb42..c967ff5b8408 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cemu
pkgdesc = Software to emulate Wii U games and applications on PC
- pkgver = 2.0.320
+ pkgver = 2.0.328
pkgrel = 1
url = https://cemu.info
install = cemu.install
@@ -31,19 +31,17 @@ pkgbase = cemu
optdepends = alsa-lib: Audio output
optdepends = vulkan-driver: Vulkan graphics
options = !strip
- source = git+https://github.com/cemu-project/Cemu#tag=v2.0-30
+ source = git+https://github.com/cemu-project/Cemu#tag=v2.0-32
source = git+https://github.com/mozilla/cubeb#commit=dc511c6b3597b6384d28949285b9289e009830ea
source = git+https://github.com/ocornut/imgui#commit=8a44c31c95c8e0217f6e1fc814cbbbcca4981f14
source = git+https://github.com/Exzap/ZArchive#commit=d2c717730092c7bf8cbb033b12fd4001b7c4d932
source = git+https://github.com/arsenm/sanitizers-cmake#commit=aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a
source = git+https://github.com/google/googletest#commit=800f5422ac9d9e0ad59cd860a2ef3a679588acb4
- source = fullscreen-f11.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = e55fee30ddb5d3d0363228feda5537607d5ae4a712590a8bb0c7ab0f1f42a347
pkgname = cemu
diff --git a/PKGBUILD b/PKGBUILD
index 3d2d96cdca30..11ed71e24f28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jeremy Kescher <jeremy@kescher.at>
pkgname=cemu
-pkgver=2.0.320
+pkgver=2.0.328
pkgrel=1
pkgdesc='Software to emulate Wii U games and applications on PC'
arch=(x86_64)
@@ -31,7 +31,7 @@ optdepends=(
)
install=cemu.install
source=(
- git+https://github.com/cemu-project/Cemu#tag=v2.0-30
+ git+https://github.com/cemu-project/Cemu#tag=v2.0-32
# submodules
git+https://github.com/mozilla/cubeb#commit=dc511c6b3597b6384d28949285b9289e009830ea
git+https://github.com/ocornut/imgui#commit=8a44c31c95c8e0217f6e1fc814cbbbcca4981f14
@@ -39,16 +39,13 @@ source=(
# cubeb submodules
git+https://github.com/arsenm/sanitizers-cmake#commit=aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a
git+https://github.com/google/googletest#commit=800f5422ac9d9e0ad59cd860a2ef3a679588acb4
- # patches
- fullscreen-f11.patch
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'e55fee30ddb5d3d0363228feda5537607d5ae4a712590a8bb0c7ab0f1f42a347')
+ 'SKIP')
pkgver() {
cd Cemu
@@ -89,8 +86,6 @@ prepare() {
# gamelist column width improvement
sed -i '/InsertColumn/s/kListIconWidth/&+8/;/SetColumnWidth/s/last_col_width/&-1/' src/gui/components/wxGameList.cpp
-
- git apply "$srcdir/fullscreen-f11.patch"
}
build() {
diff --git a/fullscreen-f11.patch b/fullscreen-f11.patch
deleted file mode 100644
index cac0b1508db4..000000000000
--- a/fullscreen-f11.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 715d2247a969e18bf1346fd2b575b0a2d5bfe792 Mon Sep 17 00:00:00 2001
-From: Nicholas F <nfrederick01@protonmail.com>
-Date: Tue, 28 Mar 2023 22:01:57 -0400
-Subject: [PATCH] Allow user to enter fullscreen with F11
-
----
- src/gui/MainWindow.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/gui/MainWindow.cpp b/src/gui/MainWindow.cpp
-index 342a1adc3..40830547f 100644
---- a/src/gui/MainWindow.cpp
-+++ b/src/gui/MainWindow.cpp
-@@ -1418,7 +1418,7 @@ void MainWindow::OnKeyUp(wxKeyEvent& event)
- const auto code = event.GetKeyCode();
- if (code == WXK_ESCAPE)
- SetFullScreen(false);
-- else if (code == WXK_RETURN && event.AltDown())
-+ else if (code == WXK_RETURN && event.AltDown() || code == WXK_F11)
- SetFullScreen(!IsFullScreen());
- else if (code == WXK_F12)
- g_window_info.has_screenshot_request = true; // async screenshot request