summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
-rwxr-xr-xcernbox3
-rwxr-xr-xcernboxcmd3
4 files changed, 47 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5088d7e9348e..fcbacdf8f01c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,25 @@
pkgbase = cernbox
pkgdesc = Synchronization client for CERN's CERNBox cloud service (based on ownCloud)
pkgver = 1.7.2_3.1
- pkgrel = 2
+ pkgrel = 3
url = http://cernbox.web.cern.ch/
arch = i686
arch = x86_64
license = GPL
depends = neon
depends = qtwebkit
- depends = qtkeychain
provides = ocsync
provides = cernboxsync
+ source = http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/x86_64/cernbox-client-1.7.2-3.1.x86_64.rpm
+ source = http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/x86_64/libcernboxsync0-1.7.2-3.1.x86_64.rpm
+ source = http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/x86_64/libqtkeychain0-0.4-8.1.x86_64.rpm
+ source = cernbox
+ source = cernboxcmd
+ md5sums = 68110fa2ae3ad0e973e46337784c00ff
+ md5sums = e5c4c22cbed3962950ae5af93d328afa
+ md5sums = 292f7710439c7a272acf16091be69ae4
+ md5sums = 12373b9b9d36a23c1ef3bad7cf30ad78
+ md5sums = d21071edeeceb0a1d6f2ef8d7f4ca4fa
pkgname = cernbox
diff --git a/PKGBUILD b/PKGBUILD
index 4ff0f571dd3c..258673e923da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,60 @@
# Maintainer: Johannes Lange (<firstname>DOT<lastname>ATcern.ch>)
pkgname=cernbox
pkgver=1.7.2_3.1
-pkgrel=2
+pkgrel=3
pkgdesc="Synchronization client for CERN's CERNBox cloud service (based on ownCloud)"
arch=('i686' 'x86_64')
url="http://cernbox.web.cern.ch/"
license=('GPL')
-depends=('neon' 'qtwebkit' 'qtkeychain')
+depends=('neon' 'qtwebkit')
provides=('ocsync' 'cernboxsync')
if [ "$CARCH" = "i686" ]; then
source=(
http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/i586/cernbox-client-${pkgver/_/-}.i586.rpm
http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/i586/libcernboxsync0-${pkgver/_/-}.i586.rpm
+ http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/i586/libqtkeychain0-0.4-8.1.i586.rpm
+ cernbox
+ cernboxcmd
+ )
+ md5sums=(
+ '6e81d85f032302cb135c108f8b02a9c5'
+ 'd00a13e8e6e032970fc6b34a7aa81be9'
+ 'a013910e30cf66b5b113c47ee0b895fc'
+ '911d014c0670d3bf7cbc622f00206339'
+ '83a60fef4c5f69b2ed91605db490a955'
)
- md5sums=('6e81d85f032302cb135c108f8b02a9c5'
- 'd00a13e8e6e032970fc6b34a7aa81be9')
elif [ "$CARCH" = "x86_64" ]; then
source=(
http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/x86_64/cernbox-client-${pkgver/_/-}.x86_64.rpm
http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/x86_64/libcernboxsync0-${pkgver/_/-}.x86_64.rpm
+ http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/x86_64/libqtkeychain0-0.4-8.1.x86_64.rpm
+ cernbox
+ cernboxcmd
+ )
+ md5sums=(
+ '68110fa2ae3ad0e973e46337784c00ff'
+ 'e5c4c22cbed3962950ae5af93d328afa'
+ '292f7710439c7a272acf16091be69ae4'
+ '911d014c0670d3bf7cbc622f00206339'
+ '83a60fef4c5f69b2ed91605db490a955'
)
- md5sums=('68110fa2ae3ad0e973e46337784c00ff'
- 'e5c4c22cbed3962950ae5af93d328afa')
fi
package() {
cp -dpr "${srcdir}/usr" "${pkgdir}"
cp -dpr "${srcdir}/etc" "${pkgdir}"
- mkdir "${pkgdir}/usr/share/pixmaps"
+ mkdir -p "${pkgdir}/usr/share/pixmaps"
cp "${pkgdir}/usr/share/icons/hicolor/128x128/apps/cernbox.png" "${pkgdir}/usr/share/pixmaps"
if [ "$CARCH" = "x86_64" ]; then
mv "${pkgdir}/usr/lib64" "${pkgdir}/usr/lib"
fi
+ mv "${pkgdir}/usr/bin/cernbox" "${pkgdir}/usr/lib/cernbox/"
+ mv "${pkgdir}/usr/bin/cernboxcmd" "${pkgdir}/usr/lib/cernbox/"
+ mv "${pkgdir}/usr/lib/libqtkeychain.so.0" "${pkgdir}/usr/lib/cernbox/"
+ mv "${pkgdir}/usr/lib/libqtkeychain.so.0.4.0" "${pkgdir}/usr/lib/cernbox/"
+ # wrapper scripts
+ cp -p "${srcdir}/cernbox" "${pkgdir}/usr/bin"
+ cp -p "${srcdir}/cernboxcmd" "${pkgdir}/usr/bin"
}
diff --git a/cernbox b/cernbox
new file mode 100755
index 000000000000..6334269ae119
--- /dev/null
+++ b/cernbox
@@ -0,0 +1,3 @@
+#!/usr/bin/bash
+
+LD_LIBRARY_PATH=/usr/lib/cernbox/:$LD_LIBRARY_PATH /usr/lib/cernbox/cernbox $@
diff --git a/cernboxcmd b/cernboxcmd
new file mode 100755
index 000000000000..ed33c7035efc
--- /dev/null
+++ b/cernboxcmd
@@ -0,0 +1,3 @@
+#!/usr/bin/bash
+
+LD_LIBRARY_PATH=/usr/lib/cernbox/:$LD_LIBRARY_PATH /usr/lib/cernbox/cernboxcmd $@