summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f91256417bf4..968a4aa18860 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = certspotter-git
pkgdesc = Certificate Transparency Log Monitor - git version
- pkgver = 0.9.r17.ge74cb79
- pkgrel = 3
+ pkgver = 0.10.r0.gb01baf8
+ pkgrel = 1
url = https://github.com/SSLMate/certspotter
arch = x86_64
arch = i686
@@ -17,6 +17,8 @@ pkgbase = certspotter-git
provides = certspotter
conflicts = certspotter
source = certspotter-git::git+https://github.com/SSLMate/certspotter
+ source = certspotter-git-fix-missing-printf.diff::https://github.com/SSLMate/certspotter/commit/6d5e2395a13267cbcc5813091586fe6d6a6c37cf.diff
sha256sums = SKIP
+ sha256sums = 7e6334317092f60d102e4ee4b536565f1417871d2070607cd272cf8dd9a39c60
pkgname = certspotter-git
diff --git a/PKGBUILD b/PKGBUILD
index 7187300220ef..3b9b981c6043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
_pkgname='certspotter'
pkgname="$_pkgname-git"
-pkgver='0.9.r17.ge74cb79'
-pkgrel='3'
+pkgver='0.10.r0.gb01baf8'
+pkgrel='1'
pkgdesc='Certificate Transparency Log Monitor - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/SSLMate/$_pkgname"
@@ -10,18 +10,26 @@ license=('MPL2')
makedepends=('git' 'go-pie>=1.5' 'golang-github-mreiferson-go-httpclient' 'golang-golang-x-net')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$pkgname::git+$url")
-sha256sums=('SKIP')
-
+source=(
+ "$pkgname::git+$url"
+ "$pkgname-fix-missing-printf.diff::$url/commit/6d5e2395a13267cbcc5813091586fe6d6a6c37cf.diff"
+)
+sha256sums=('SKIP'
+ '7e6334317092f60d102e4ee4b536565f1417871d2070607cd272cf8dd9a39c60')
+
+_sourcedirectory="$pkgname"
_builddir="$pkgname-build"
_buildpath="src/software.sslmate.com/src/$_pkgname"
_bindir="$pkgname-bin"
prepare() {
- cd "$srcdir/"
+ cd "$srcdir/$_sourcedirectory/"
+ # https://github.com/SSLMate/certspotter/pull/40
+ patch --forward -p1 < "$srcdir/$pkgname-fix-missing-printf.diff"
+ cd "$srcdir/"
mkdir -p "$_builddir/$(echo "$_buildpath" | rev | cut -d '/' -f 2- | rev)/"
- mv "$pkgname/" "$_builddir/$_buildpath/"
+ mv "$_sourcedirectory/" "$_builddir/$_buildpath/"
mkdir -p "$_bindir/"
}