summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--0003_dev_trans_start.patch23
-rw-r--r--0004_last_rx-4.11.patch23
-rw-r--r--0005_signal_pending-4.11.patch28
-rw-r--r--PKGBUILD46
-rw-r--r--ceton_infinitv.install9
-rw-r--r--kernel.patch11
-rw-r--r--no-date-time-warn.patch11
8 files changed, 176 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1670fcc73d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = ceton_infinitv
+ pkgdesc = Driver for Ceton InfiniTV
+ pkgver = 2013.0326.2226
+ pkgrel = 4
+ url = http://cetoncorp.com/infinitv_support/linux_drivers
+ install = ceton_infinitv.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = linux-headers
+ source = http://www.cetoncorp.com/downloads/ceton_infinitv_linux_driver_2013_0326_2226.tar.gz
+ source = kernel.patch
+ source = no-date-time-warn.patch
+ source = 0003_dev_trans_start.patch
+ source = 0004_last_rx-4.11.patch
+ source = 0005_signal_pending-4.11.patch
+ sha256sums = 36f7cf010a705b283f165e9dd611dac6ef4729c55466752c3b70f3ffcc6d47d2
+ sha256sums = dd642a60ba15bdada535beb000d8bddd87d0f97c70b1d37f7fa0e0af9e6b464c
+ sha256sums = 929a93e8fc35746de1a515e23a3dfe30e39573ea40d0c2e492be59f630f87918
+ sha256sums = b2f56dfdb49fa59545beb8c61e4e021864c8187d604cbbeec2179dcc15a00fbf
+ sha256sums = 95b44af29a6ea642c5c54652d32b275202c83b28ec9f5bf82df6a294d8858097
+ sha256sums = 25217e4af33e1c1348a07891a1ef692ec628df7a51bd901d54ffc4fbf08d3fe6
+
+pkgname = ceton_infinitv
+
diff --git a/0003_dev_trans_start.patch b/0003_dev_trans_start.patch
new file mode 100644
index 000000000000..fdcb514e4924
--- /dev/null
+++ b/0003_dev_trans_start.patch
@@ -0,0 +1,23 @@
+diff -urpN ceton_infinitv_linux_driver/ctn91xx_net.c ceton_infinitv_linux_driver-fixed/ctn91xx_net.c
+--- ceton_infinitv_linux_driver/ctn91xx_net.c 2013-03-27 01:26:59.000000000 -0400
++++ ceton_infinitv_linux_driver-fixed/ctn91xx_net.c 2017-11-03 01:20:41.041441464 -0400
+@@ -1,6 +1,7 @@
+ #include "ctn91xx_net.h"
+ #include "ctn91xx_kal.h"
+ #include "ctn91xx_util.h"
++#include <linux/version.h>
+
+ #define INCLUDE_NET_DBG 0
+ #define PRINT_TRAFFIC 0
+@@ -228,7 +229,11 @@ static int ctn91xx_net_start_xmit( struc
+ sdump_buffer( skb->data, skb->len, "tx");
+ #endif
+
++#if LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,31)
+ ndev->trans_start = jiffies;
++#else
++ dev_trans_start(ndev);
++#endif
+ ctn91xx_write8( 1, msg_base, MSG_BUFFER_MSG_AVAIL );
+
+ } else {
diff --git a/0004_last_rx-4.11.patch b/0004_last_rx-4.11.patch
new file mode 100644
index 000000000000..d21830c8bf30
--- /dev/null
+++ b/0004_last_rx-4.11.patch
@@ -0,0 +1,23 @@
+diff -urpN ceton_infinitv_linux_driver/ctn91xx_net.c ceton_infinitv_linux_driver-fixed/ctn91xx_net.c
+--- ceton_infinitv_linux_driver/ctn91xx_net.c 2017-11-03 01:31:21.766659920 -0400
++++ ceton_infinitv_linux_driver-fixed/ctn91xx_net.c 2017-11-03 01:34:20.161911675 -0400
+@@ -317,7 +317,9 @@ void ctn91xx_net_rx_skb( ctn91xx_dev_t*
+ skb->protocol = eth_type_trans( skb, netdev );
+ netif_rx( skb );
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,11,0)
+ netdev->last_rx = jiffies;
++#endif
+ priv->stats.rx_bytes += rx_len;
+ priv->stats.rx_packets++;
+
+@@ -367,7 +369,9 @@ irqreturn_t ctn91xx_net_isr_ex(int irq,
+ skb->protocol = eth_type_trans( skb, netdev );
+ netif_rx( skb );
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,11,0)
+ netdev->last_rx = jiffies;
++#endif
+ priv->stats.rx_bytes += rx_len;
+ priv->stats.rx_packets++;
+ } else {
diff --git a/0005_signal_pending-4.11.patch b/0005_signal_pending-4.11.patch
new file mode 100644
index 000000000000..83c48b1b831e
--- /dev/null
+++ b/0005_signal_pending-4.11.patch
@@ -0,0 +1,28 @@
+diff -urpN ceton_infinitv_linux_driver/ctn91xx_kal.h ceton_infinitv_linux_driver-fixed/ctn91xx_kal.h
+--- ceton_infinitv_linux_driver/ctn91xx_kal.h 2013-03-27 01:26:58.000000000 -0400
++++ ceton_infinitv_linux_driver-fixed/ctn91xx_kal.h 2017-11-03 01:48:13.386598059 -0400
+@@ -2,19 +2,23 @@
+ #define _CTN91XX_KAL_H
+
+ #if defined(__KERNEL__)
++#include <linux/version.h>
+ #include <linux/types.h>
+ #include <linux/module.h>
+ #include <linux/init.h>
+ #include <linux/pci.h>
+ #include <linux/interrupt.h>
+ #include <linux/miscdevice.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++#include <linux/sched/signal.h>
++#else
+ #include <linux/sched.h>
++#endif
+ #include <linux/pagemap.h>
+ #include <linux/spinlock.h>
+ #include <linux/workqueue.h>
+ #include <linux/fs.h>
+ #include <linux/delay.h>
+-#include <linux/version.h>
+ #include <linux/poll.h>
+ #include <linux/time.h>
+ #include <linux/i2c.h>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24c3651bad1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Bill Durr <billyburly@gmail.com>
+# Original by: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=ceton_infinitv
+pkgver=2013.0326.2226
+pkgrel=4
+pkgdesc="Driver for Ceton InfiniTV"
+arch=('i686' 'x86_64')
+url="http://cetoncorp.com/infinitv_support/linux_drivers"
+license=('GPL')
+depends=('linux-headers')
+source=(http://www.cetoncorp.com/downloads/${pkgname}_linux_driver_2013_0326_2226.tar.gz
+ kernel.patch
+ no-date-time-warn.patch
+ 0003_dev_trans_start.patch
+ 0004_last_rx-4.11.patch
+ 0005_signal_pending-4.11.patch)
+sha256sums=('36f7cf010a705b283f165e9dd611dac6ef4729c55466752c3b70f3ffcc6d47d2'
+ 'dd642a60ba15bdada535beb000d8bddd87d0f97c70b1d37f7fa0e0af9e6b464c'
+ '929a93e8fc35746de1a515e23a3dfe30e39573ea40d0c2e492be59f630f87918'
+ 'b2f56dfdb49fa59545beb8c61e4e021864c8187d604cbbeec2179dcc15a00fbf'
+ '95b44af29a6ea642c5c54652d32b275202c83b28ec9f5bf82df6a294d8858097'
+ '25217e4af33e1c1348a07891a1ef692ec628df7a51bd901d54ffc4fbf08d3fe6')
+install=${pkgname}.install
+
+prepare() {
+ cd $srcdir/${pkgname}_linux_driver
+ patch -p1 -i $srcdir/kernel.patch
+ patch -p1 -i $srcdir/no-date-time-warn.patch
+ patch -p1 -i $srcdir/0003_dev_trans_start.patch
+ patch -p1 -i $srcdir/0004_last_rx-4.11.patch
+ patch -p1 -i $srcdir/0005_signal_pending-4.11.patch
+}
+
+build() {
+ cd "$srcdir/${pkgname}_linux_driver"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}_linux_driver"
+ KERNEL_VERSION=`pacman -Qi linux | grep "Version" | sed 's/^Version\s*:\s//'`
+ install -D -m644 ctn91xx.ko ${pkgdir}/usr/lib/modules/${KERNEL_VERSION}-ARCH/extramodules/ctn91xx.ko
+ gzip -9 ${pkgdir}/usr/lib/modules/${KERNEL_VERSION}-ARCH/extramodules/ctn91xx.ko
+ install -D -m644 98-ctn91xx.rules ${pkgdir}/etc/udev/rules.d/98-ctn91xx.rules
+}
diff --git a/ceton_infinitv.install b/ceton_infinitv.install
new file mode 100644
index 000000000000..19de4c0d6ca2
--- /dev/null
+++ b/ceton_infinitv.install
@@ -0,0 +1,9 @@
+KERNEL_VER=`pacman -Qi linux | grep "Version" | sed 's/^Version\s*:\s//'`
+
+post_install() {
+ depmod -ae ${KERNEL_VER}-ARCH
+}
+
+post_upgrade() {
+ depmod -ae ${KERNEL_VER}-ARCH
+}
diff --git a/kernel.patch b/kernel.patch
new file mode 100644
index 000000000000..d4f6785263af
--- /dev/null
+++ b/kernel.patch
@@ -0,0 +1,11 @@
+diff -aur ceton_infinitv_linux_driver-orig/Makefile ceton_infinitv_linux_driver/Makefile
+--- ceton_infinitv_linux_driver-orig/Makefile 2013-03-27 01:26:59.000000000 -0400
++++ ceton_infinitv_linux_driver/Makefile 2014-11-11 21:54:10.425414319 -0500
+@@ -1,5 +1,5 @@
+-KERNEL_VERSION := $(shell uname -r)
+-KERNEL_DIR := /lib/modules/$(KERNEL_VERSION)/build
++KERNEL_VERSION := $(shell pacman -Qi linux | grep "Version" | sed 's/^Version\s*:\s//')
++KERNEL_DIR := /lib/modules/$(KERNEL_VERSION)-ARCH/build
+
+ PWD := $(shell pwd)
+
diff --git a/no-date-time-warn.patch b/no-date-time-warn.patch
new file mode 100644
index 000000000000..3f7d9b4f0113
--- /dev/null
+++ b/no-date-time-warn.patch
@@ -0,0 +1,11 @@
+diff -aur ceton_infinitv_linux_driver-orig/Makefile ceton_infinitv_linux_driver/Makefile
+--- ceton_infinitv_linux_driver-orig/Makefile 2014-11-11 21:38:27.990742939 -0500
++++ ceton_infinitv_linux_driver/Makefile 2014-11-11 21:41:41.181569523 -0500
+@@ -23,6 +23,7 @@
+ EXTRA_CFLAGS := -DLINUX -DUSE_PCI=1 -DUSE_LEON=0 -DHAS_MPEG_DMA=1 -DUSE_INTERNAL=0
+ SOURCES += ctn91xx_pci.o ctn91xx_rtp.o
+ endif
++EXTRA_CFLAGS += -Wno-date-time
+
+ ctn91xx_builtin-objs := $(SOURCES)
+