summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7952cad5548..d2c9b0c1303b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cfengine
pkgdesc = Automated suite of programs for configuring and maintaining Unix-like computers.
pkgver = 3.10.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.cfengine.org
install = cfengine.install
arch = i686
@@ -14,6 +14,7 @@ pkgbase = cfengine
depends = pam
depends = libyaml
depends = curl
+ depends = openssl-1.0
optdepends = libvirt
optdepends = postgresql-libs
optdepends = libmariadbclient
diff --git a/PKGBUILD b/PKGBUILD
index 27f04bc67dc2..227aaf8e08f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@
pkgname=cfengine
pkgver=3.10.1
-pkgrel=1
+pkgrel=2
pkgdesc='Automated suite of programs for configuring and maintaining Unix-like computers.'
url='http://www.cfengine.org'
license=('GPL3')
arch=('i686' 'x86_64')
-depends=('lmdb' 'pcre' 'libxml2' 'pam' 'libyaml' 'curl')
+depends=('lmdb' 'pcre' 'libxml2' 'pam' 'libyaml' 'curl' 'openssl-1.0')
makedepends=('which')
optdepends=('libvirt' 'postgresql-libs' 'libmariadbclient' 'acl')
install=${pkgname}.install
@@ -33,6 +33,8 @@ md5sums=('ae7e2dc8b20faa89089002c9b9fd4e0a'
build() {
cd ${srcdir}/${pkgname}-${pkgver}
+ export CFLAGS=-I/usr/include/openssl-1.0
+ export LDFLAGS=-L/usr/lib/openssl-1.0
./configure \
--prefix=/usr \
--with-workdir=/var/${pkgname} \