summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD78
-rw-r--r--cf-execd.service11
-rw-r--r--cf-monitord.service11
-rw-r--r--cf-serverd.service11
5 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ec6fd3fe1c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = cfengine
+ pkgdesc = automated suite of programs for configuring and maintaining Unix-like computers.
+ pkgver = 3.5.0
+ pkgrel = 2
+ url = http://www.cfengine.org
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qdbm
+ depends = openssl
+ depends = pcre
+ depends = acl
+ depends = libxml2
+ optdepends = tokyocabinet
+ optdepends = libvirt
+ optdepends = postgresql-libs
+ optdepends = libmariadbclient
+ source = cfengine-3.5.0.tar.gz::http://cfengine.com/source-code/download?file=cfengine-3.5.0.tar.gz
+ source = cf-execd.service
+ source = cf-monitord.service
+ source = cf-serverd.service
+ md5sums = 06ceba929f4d67e25599cf27d6e45cc0
+ md5sums = bf64e1dedbcef5a74e3b585076135c87
+ md5sums = c56bde562ec29c1533433a320f4f4b5d
+ md5sums = 2a3aed38b03b14335a70103e45d42ee8
+
+pkgname = cfengine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83bd91d75f6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+# Contributor: Christian Berendt <christian@thorlin.de>
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=cfengine
+pkgver=3.5.0
+pkgrel=2
+pkgdesc="automated suite of programs for configuring and maintaining Unix-like computers."
+url="http://www.cfengine.org"
+license=('GPL3')
+arch=('i686' 'x86_64')
+# depends on a bunch of things because of specific bundles, should be
+# modular! Trying to have as little here as possible
+depends=('qdbm' 'openssl' 'pcre' 'acl' 'libxml2')
+# do not depend on things which are not packages, only in AUR, sadly qdbm
+# is required (as one of them is required)
+# also libvirt makes sence for hosting servers, but not applicances (it
+# has far too many dependencies on X11 libraries)
+# database support is considered optional, enable if needed
+optdepends=('tokyocabinet' 'libvirt' 'postgresql-libs' 'libmariadbclient')
+
+source=(
+ "${pkgname}-${pkgver}.tar.gz::http://cfengine.com/source-code/download?file=${pkgname}-${pkgver}.tar.gz"
+ "cf-execd.service"
+ "cf-monitord.service"
+ "cf-serverd.service"
+)
+md5sums=('06ceba929f4d67e25599cf27d6e45cc0'
+ 'bf64e1dedbcef5a74e3b585076135c87'
+ 'c56bde562ec29c1533433a320f4f4b5d'
+ '2a3aed38b03b14335a70103e45d42ee8')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # Remove one (or both) of the --with-mysql and/or --with-postgresql
+ # lines if you want to reduce dependency chain"
+ ./configure \
+ --prefix=/usr \
+ --with-openssl \
+ --with-pcre \
+ --without-libvirt \
+ --with-libacl=check \
+ --with-libxml2 \
+ --without-postgresql \
+ --without-mysql \
+ --with-workdir=/srv/cfengine \
+ --with-qdbm \
+ --without-tokyocabinet
+
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ make DESTDIR=$pkgdir install
+
+ install -D -m644 ${srcdir}/cf-execd.service \
+ ${pkgdir}/usr/lib/systemd/system/cf-execd.service
+ install -D -m644 ${srcdir}/cf-serverd.service \
+ ${pkgdir}/usr/lib/systemd/system/cf-serverd.service
+ install -D -m644 ${srcdir}/cf-monitord.service \
+ ${pkgdir}/usr/lib/systemd/system/cf-monitord.service
+}
+
+# vim:set ts=2 sw=2 et:
+
diff --git a/cf-execd.service b/cf-execd.service
new file mode 100644
index 000000000000..12d0fb9750dd
--- /dev/null
+++ b/cf-execd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=CFEngine Execution Daemon
+After=syslog.target
+
+[Service]
+ExecStart=/usr/bin/cf-execd
+Type=forking
+PIDFile=/srv/cfengine/cf-execd.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/cf-monitord.service b/cf-monitord.service
new file mode 100644
index 000000000000..584c26e25f53
--- /dev/null
+++ b/cf-monitord.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=CFEngine Monitoring Daemon
+After=syslog.target
+
+[Service]
+ExecStart=/usr/bin/cf-monitord
+Type=forking
+PIDFile=/srv/cfengine/cf-monitord.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/cf-serverd.service b/cf-serverd.service
new file mode 100644
index 000000000000..14f6014235bc
--- /dev/null
+++ b/cf-serverd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=CFEngine Server Daemon
+After=syslog.target
+
+[Service]
+ExecStart=/usr/bin/cf-serverd
+Type=forking
+PIDFile=/srv/cfengine/cf-serverd.pid
+
+[Install]
+WantedBy=multi-user.target