summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD43
3 files changed, 46 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33a88bbd3384..db241da133f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,21 @@
pkgbase = cfunge
pkgdesc = Fast, small and standard conforming Befunge98 interpreter
- pkgver = 0.9.0
- pkgrel = 3
- url = https://github.com/VorpalBlade/cfunge/
+ pkgver = 1,001
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/VorpalBlade/cfunge
arch = x86_64
arch = i686
- license = GPL
+ arch = arm7h
+ arch = aarch64
+ license = GPL3
makedepends = cmake
makedepends = ninja
- source = cfunge-0.9.0.tar.gz::https://github.com/VorpalBlade/cfunge/archive/0.9.0.tar.gz
- sha256sums = bc670123064ea8b75acc1fbba1559cfe3f28d62bd56e5455c9e0fe660474d53a
+ makedepends = git
+ depends = libbsd
+ source = cfunge-1,001.tar.gz::https://github.com/VorpalBlade/cfunge/archive/1,001.tar.gz
+ source = mycology::git+https://github.com/Deewiant/Mycology#commit=3787e42c3d4f0b735a09129a205e3e4df848558c
+ sha256sums = 631f61abaeaf03a15a33c01cd98e8c4887087c16360084d45bf65feb60996f89
+ sha256sums = SKIP
pkgname = cfunge
-
diff --git a/.gitignore b/.gitignore
index 4506c39191ba..1a5064817ef6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
+/*.tar.gz
+/*.tar.zst
+/mycology/
/pkg/
/src/
-/cfunge-*.tar.gz
-/cfunge-*.tar.xz
-/cfunge-*.tar.xz.sig
diff --git a/PKGBUILD b/PKGBUILD
index bfbc06778d0f..7b081cc56a25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,46 @@
-# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Maintainer: Arvid Norlander <VorpalBlade@users.noreply.github.com>
+# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: Angus Gibson <darthshrine@gmail.com>
pkgname=cfunge
-pkgver=0.9.0
-pkgrel=3
+pkgver=1,001
+pkgrel=1
+epoch=1
pkgdesc='Fast, small and standard conforming Befunge98 interpreter'
-arch=('x86_64' 'i686')
-url='https://github.com/VorpalBlade/cfunge/'
-license=('GPL')
-makedepends=('cmake' 'ninja')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/VorpalBlade/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('bc670123064ea8b75acc1fbba1559cfe3f28d62bd56e5455c9e0fe660474d53a')
+arch=('x86_64' 'i686' 'arm7h' 'aarch64')
+url='https://github.com/VorpalBlade/cfunge'
+license=('GPL3')
+depends=('libbsd')
+makedepends=('cmake' 'ninja' 'git')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/VorpalBlade/$pkgname/archive/$pkgver.tar.gz"
+ 'mycology::git+https://github.com/Deewiant/Mycology#commit=3787e42c3d4f0b735a09129a205e3e4df848558c')
+sha256sums=('631f61abaeaf03a15a33c01cd98e8c4887087c16360084d45bf65feb60996f89'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname-${pkgver/,/-}/tests/mycology/"
+ rm -rf src
+ ln -s "$srcdir/mycolgy" src
+}
build() {
- mkdir -p build
- cd build
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
cmake \
-G Ninja \
-D CMAKE_INSTALL_PREFIX=/usr \
- "../$pkgname-$pkgver"
+ "../$pkgname-${pkgver/,/-}"
ninja
}
+check() {
+ cd "$srcdir/build"
+ ctest -k0 -j8 --output-on-failure
+}
+
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ cd "$srcdir/build"
+ DESTDIR="$pkgdir/" ninja install
}
# vim:set ts=2 sw=2 et: