summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD40
2 files changed, 25 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89fafe3396fe..3001f46899bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = cgal-swig-bindings
pkgdesc = CGAL bindings using SWIG
- pkgver = r909.f579deb
+ pkgver = 5.5.2.post202303131425.r1.gd5e2662
pkgrel = 1
url = https://github.com/CGAL/cgal-swig-bindings
arch = x86_64
- license = custom: Boost
+ license = GPL3
makedepends = cgal
makedepends = cmake
makedepends = swig
makedepends = eigen
makedepends = python-numpy
makedepends = jdk-openjdk
- makedepends = tbb
+ makedepends = onetbb
makedepends = boost
makedepends = git
source = git+https://github.com/CGAL/cgal-swig-bindings.git
@@ -20,9 +20,9 @@ pkgbase = cgal-swig-bindings
pkgname = python-cgal
depends = python-numpy
depends = boost
- depends = tbb
+ depends = onetbb
pkgname = java-cgal
depends = jdk-openjdk
depends = boost
- depends = tbb
+ depends = onetbb
diff --git a/PKGBUILD b/PKGBUILD
index 8bd4f6754af8..caf45ee59bf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,51 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: xantares <xantares09@hotmail.com>
pkgbase=cgal-swig-bindings
-pkgname=('python-cgal' 'java-cgal')
-pkgver=r909.f579deb
+pkgname=(python-cgal java-cgal)
+pkgver=5.5.2.post202303131425.r1.gd5e2662
pkgrel=1
-pkgdesc='CGAL bindings using SWIG '
-arch=('x86_64')
-license=('custom: Boost')
+pkgdesc="CGAL bindings using SWIG"
+arch=(x86_64)
+license=(GPL3)
url="https://github.com/CGAL/${pkgbase}"
-makedepends=('cgal' 'cmake' 'swig' 'eigen' 'python-numpy' 'jdk-openjdk' 'tbb' 'boost' 'git')
-source=("git+${url}.git")
+makedepends=(cgal cmake swig eigen python-numpy jdk-openjdk onetbb boost git)
+source=(git+${url}.git)
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgbase}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${pkgbase}
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgbase}"
- mkdir -p build && pushd build
cmake \
+ -S ${pkgbase} \
+ -B build \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
-DBUILD_JAVA=ON \
-DBUILD_PYTHON=ON \
- -DBUILD_RUBY=OFF \
- ..
- make
+ -DBUILD_RUBY=OFF
+ cmake --build build --target all
+
ctest -j2 -R python -E polyline_simplification_2 --output-on-failure
}
package_python-cgal() {
- depends=('python-numpy' 'boost' 'tbb')
+ depends=(python-numpy boost onetbb)
- cd "$srcdir/${pkgbase}"/build
+ cd build
python_dir=$(python -c "from distutils import sysconfig; print(sysconfig.get_python_lib())")
install -d "$pkgdir"/${python_dir}
cp -r build-python/CGAL "$pkgdir"/${python_dir}
rm "$pkgdir"/${python_dir}/CGAL/CGAL_*PYTHON_wrap.cxx
- # make DESTDIR="$pkgdir" install
+ # make DESTDIR="$pkgdir" install
}
package_java-cgal() {
- depends=('jdk-openjdk' 'boost' 'tbb')
+ depends=(jdk-openjdk boost onetbb)
- cd "$srcdir/${pkgbase}"/build
+ cd build
install -d "$pkgdir"/usr/share/java/
cp -r build-java/CGAL "$pkgdir"/usr/share/java
# make DESTDIR="$pkgdir" install