summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--fix_pc_file.patch11
3 files changed, 21 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f80e19e877e..c8f33a7b9d0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = cgicc
pkgdesc = C++ library that simplifies the creation of CGI applications
pkgver = 3.2.16
- pkgrel = 3
+ pkgrel = 4
url = https://www.gnu.org/software/cgicc/
arch = i686
arch = x86_64
license = LGPL3
makedepends = doxygen
- options = staticlibs
source = https://ftp.gnu.org/gnu/cgicc/cgicc-3.2.16.tar.gz
+ source = fix_pc_file.patch
sha256sums = 9dceb36d2da52791ee11f2fb5bb6435c22e69ef50f38073c4329386b883d5aaa
+ sha256sums = 5a0b29ce1028cba8d7cc7d52244077c030ed8f447e169a7afa946b376150b35b
pkgname = cgicc
diff --git a/PKGBUILD b/PKGBUILD
index 3f9680b5b9a6..1257e8e63c23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,21 @@
# Maintainer: Dario Ostuni <another.code.996@gmail.com>
pkgname=cgicc
pkgver=3.2.16
-pkgrel=3
+pkgrel=4
pkgdesc="C++ library that simplifies the creation of CGI applications"
arch=('i686' 'x86_64')
url="https://www.gnu.org/software/cgicc/"
license=('LGPL3')
makedepends=('doxygen')
-options=('staticlibs')
-source=("https://ftp.gnu.org/gnu/cgicc/$pkgname-$pkgver.tar.gz")
-sha256sums=('9dceb36d2da52791ee11f2fb5bb6435c22e69ef50f38073c4329386b883d5aaa')
+options=()
+source=("https://ftp.gnu.org/gnu/cgicc/$pkgname-$pkgver.tar.gz"
+ "fix_pc_file.patch")
+sha256sums=('9dceb36d2da52791ee11f2fb5bb6435c22e69ef50f38073c4329386b883d5aaa'
+ '5a0b29ce1028cba8d7cc7d52244077c030ed8f447e169a7afa946b376150b35b')
build() {
cd "$pkgname-$pkgver"
+ patch -p2 -b -z .orig < "${srcdir}/fix_pc_file.patch"
./configure --prefix=/usr
make
}
diff --git a/fix_pc_file.patch b/fix_pc_file.patch
new file mode 100644
index 000000000000..c144233f3950
--- /dev/null
+++ b/fix_pc_file.patch
@@ -0,0 +1,11 @@
+--- src/cgicc-3.2.16/cgicc.pc.in.orig 2015-11-11 20:54:03.569298259 -0500
++++ src/cgicc-3.2.16/cgicc.pc.in 2015-11-11 20:54:09.266042294 -0500
+@@ -7,5 +7,5 @@
+ Description: GNU cgicc is an ANSI C++ compliant class library that greatly simplifies the creation of CGI applications for the World Wide Web.
+ Requires:
+ Version: @VERSION@
+-Libs: -L${libdir}
+-Cflags:
+\ No newline at end of file
++Libs: -L${libdir} -lcgicc
++Cflags: -I${includedir}