summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
-rw-r--r--font.patch15
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f253fbd4615d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = chaos-equations-git
+ pkgdesc = Simple mathematical art
+ pkgver = r19.0fc5e2f
+ pkgrel = 1
+ url = https://github.com/MadManGaz/Chaos-Equations
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ depends = sfml
+ source = git+https://github.com/MadManGaz/Chaos-Equations.git
+ source = font.patch
+ sha256sums = SKIP
+ sha256sums = 0778dcb913966d5546c0f9e1df065040bd790971c85eb67355a363bd3cd24c32
+
+pkgname = chaos-equations-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a8b49506574
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
+
+pkgname=chaos-equations-git
+pkgver=r19.0fc5e2f
+pkgrel=1
+pkgdesc='Simple mathematical art'
+arch=($CARCH)
+url='https://github.com/MadManGaz/Chaos-Equations'
+license=(MIT)
+depends=(sfml)
+makedepends=(git cmake)
+source=("git+$url.git" font.patch)
+sha256sums=('SKIP'
+ '0778dcb913966d5546c0f9e1df065040bd790971c85eb67355a363bd3cd24c32')
+
+pkgver() {
+ cd Chaos-Equations
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd Chaos-Equations
+ patch -p1 -i ../font.patch
+}
+
+build() {
+ cmake -B build -G "Unix Makefiles" -S Chaos-Equations \
+ -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
+}
+
+package() {
+ install -Dm755 build/chaosequations -t "$pkgdir/usr/bin/"
+ install -Dm644 Chaos-Equations/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}
diff --git a/font.patch b/font.patch
new file mode 100644
index 000000000000..3125a277140b
--- /dev/null
+++ b/font.patch
@@ -0,0 +1,15 @@
+--- a/Main.cpp 2021-03-01 21:39:08.883391639 +0000
++++ b/Main.cpp 2021-03-01 21:40:48.769454085 +0000
+@@ -122,9 +122,9 @@
+ static std::string MakeEquationStr(double *params) {
+ std::stringstream ss;
+ bool isFirst = true;
+- SIGN_OR_SKIP(0, "x\u00b2");
+- SIGN_OR_SKIP(1, "y\u00b2");
+- SIGN_OR_SKIP(2, "t\u00b2");
++ SIGN_OR_SKIP(0, "x^2");
++ SIGN_OR_SKIP(1, "y^2");
++ SIGN_OR_SKIP(2, "t^2");
+ SIGN_OR_SKIP(3, "xy");
+ SIGN_OR_SKIP(4, "xt");
+ SIGN_OR_SKIP(5, "yt");