summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD55
-rw-r--r--charybdis.install15
-rw-r--r--charybdis.service12
-rw-r--r--charybdis.tmpfiles1
6 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54d9d6c36cd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by makepkg 5.0.0
+# Thu Mar 3 16:53:40 UTC 2016
+pkgbase = charybdis
+ pkgdesc = A highly scalable IRCv3-compliant IRCd
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = http://www.charybdis.io/
+ install = charybdis.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = bison
+ depends = flex
+ depends = openssl
+ depends = zlib
+ provides = charybdis
+ options = !strip
+ source = http://distfiles.charybdis.io/charybdis-3.5.0.tar.bz2
+ source = charybdis.service
+ source = charybdis.tmpfiles
+ sha256sums = 8bdf12b5389c896520c42c8a7f918212c25e81c8f5a823a8aca595603da93014
+ sha256sums = 044f3567ed865365e76581942e1b28ba4f7193dd6c8022616ea0894295272062
+ sha256sums = 2fcc284f060cafa9a6df0b010de44833b248169ab11c6289f54227ab87068c29
+
+pkgname = charybdis
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e1fc0939683
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg
+src
+*.xz
+*.bz2
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0491ef1f6d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jonathan Raffre (nekonyuu) <nk@nyuu.eu>
+# Contributor (based on): Bjorn Neergaard (neersighted) <bjorn@neersighted.com>
+# Contributor: JD Horelick <jdhore1@gmail.com>
+# Contributor: Mantas Mikulėnas <grawity@gmail.com>
+
+_pkgname=charybdis
+pkgname=charybdis
+pkgver=3.5.0
+pkgrel=1
+pkgdesc='A highly scalable IRCv3-compliant IRCd'
+url='http://www.charybdis.io/'
+license=('GPL2')
+options=('!strip')
+install=charybdis.install
+source=("http://distfiles.charybdis.io/charybdis-${pkgver}.tar.bz2"
+ 'charybdis.service'
+ 'charybdis.tmpfiles')
+sha256sums=('8bdf12b5389c896520c42c8a7f918212c25e81c8f5a823a8aca595603da93014'
+ '044f3567ed865365e76581942e1b28ba4f7193dd6c8022616ea0894295272062'
+ '2fcc284f060cafa9a6df0b010de44833b248169ab11c6289f54227ab87068c29')
+arch=('i686' 'x86_64')
+depends=('bison' 'flex' 'openssl' 'zlib')
+provides=('charybdis')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Configure the build.
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/charybdis \
+ --localstatedir=/var \
+ --enable-fhs-paths \
+ --with-rundir=/run \
+ --with-program-prefix=charybdis-
+
+ # Build it!
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Install the program.
+ make DESTDIR="${pkgdir}" install
+
+ # Install the docs.
+ install -Dm644 -d docs "${pkgdir}/usr/share/docs/charybdis"
+
+ # Install the service.
+ install -Dm644 "${srcdir}/charybdis.service" "${pkgdir}/usr/lib/systemd/system/charybdis.service"
+ install -Dm644 "${srcdir}/charybdis.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/charybdis.conf"
+}
+
+# vim: ft=sh ts=2 sw=2 et
diff --git a/charybdis.install b/charybdis.install
new file mode 100644
index 000000000000..204219d3ab8b
--- /dev/null
+++ b/charybdis.install
@@ -0,0 +1,15 @@
+post_install() {
+ getent passwd charybdis >&/dev/null ||
+ useradd -d '/var/charybdis' -r charybdis
+
+ chown charybdis:charybdis {/etc,/var,/var/log}/charybdis
+
+ systemd-tmpfiles --create charybdis.conf
+}
+
+post_remove() {
+ getent passwd charybdis >&/dev/null &&
+ userdel charybdis
+}
+
+# vim: ft=sh ts=2 sw=2 et
diff --git a/charybdis.service b/charybdis.service
new file mode 100644
index 000000000000..6b4767a19e55
--- /dev/null
+++ b/charybdis.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Charybdis IRCd
+After=network.target
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/charybdis-ircd
+User=charybdis
+PIDFile=/run/charybdis/ircd.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/charybdis.tmpfiles b/charybdis.tmpfiles
new file mode 100644
index 000000000000..e10acb3c07c6
--- /dev/null
+++ b/charybdis.tmpfiles
@@ -0,0 +1 @@
+d /run/charybdis 0755 charybdis charybdis -