summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f5d159b9a37..13d2ce9d4531 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = charybdis
- pkgdesc = A highly scalable IRCv3-compliant IRCd
+ pkgdesc = Scalable IRCv3.2 server for large, community-oriented networks
pkgver = 4.1.2
- pkgrel = 3
- url = https://charybdis-ircd.github.io/
+ pkgrel = 4
+ url = https://charybdis-ircd.github.io
install = charybdis.install
arch = i686
arch = x86_64
license = GPL2
+ makedepends = openssl
+ makedepends = mbedtls
+ makedepends = gnutls
depends = bison
depends = flex
depends = openssl
depends = zlib
- provides = charybdis
+ provides = charybdis-git
conflicts = charybdis-git
options = !strip
source = https://github.com/charybdis-ircd/charybdis/archive/charybdis-4.1.2.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 5ef3eaa6dfe4..e0846310681c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,21 @@
# Maintainer: Jonathan Raffre (nekonyuu) <nk@nyuu.eu>
+# Co-Maintainer: Felix Golatofski <contact@xdfr.de>
# Contributor (based on): Bjorn Neergaard (neersighted) <bjorn@neersighted.com>
# Contributor: JD Horelick <jdhore1@gmail.com>
# Contributor: Mantas Mikulėnas <grawity@gmail.com>
-_pkgname=charybdis
pkgname=charybdis
pkgver=4.1.2
-pkgrel=3
-pkgdesc='A highly scalable IRCv3-compliant IRCd'
-url='https://charybdis-ircd.github.io/'
+pkgrel=4
+pkgdesc='Scalable IRCv3.2 server for large, community-oriented networks'
+arch=('i686' 'x86_64')
+url="https://charybdis-ircd.github.io"
license=('GPL2')
options=('!strip')
+depends=('bison' 'flex' 'openssl' 'zlib')
+makedepends=('openssl' 'mbedtls' 'gnutls')
+conflicts=("${pkgname}-git")
+provides=("${pkgname}-git")
install=charybdis.install
source=("https://github.com/charybdis-ircd/charybdis/archive/charybdis-${pkgver}.tar.gz"
'charybdis.service'
@@ -18,13 +23,9 @@ source=("https://github.com/charybdis-ircd/charybdis/archive/charybdis-${pkgver}
sha256sums=('a3f4e572877c5a3abdab3af652746c0682f0c41b3f9e3c9866315f5d03f2bb57'
'a890d3a4fddd34b475c1c2e5f47f790af3bcebc3539c4a92a7343829fdbce563'
'2fcc284f060cafa9a6df0b010de44833b248169ab11c6289f54227ab87068c29')
-arch=('i686' 'x86_64')
-depends=('bison' 'flex' 'openssl' 'zlib')
-conflicts=('charybdis-git')
-provides=('charybdis')
build() {
- cd "${srcdir}/${_pkgname}-${_pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
# Set up the build.
./autogen.sh
@@ -36,6 +37,9 @@ build() {
--localstatedir=/var \
--enable-fhs-paths \
--with-rundir=/run \
+ --enable-openssl \
+ --enable-mbedtls \
+ --enable-gnutls \
--with-program-prefix=charybdis-
# Build it!
@@ -43,7 +47,7 @@ build() {
}
package() {
- cd "${srcdir}/${_pkgname}-${_pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
# Install the program.
make DESTDIR="${pkgdir}" install