summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD67
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b5f8ca6b26e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = chaskis
+ pkgdesc = A generic framework written in C# for making IRC Bots.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/xforever1313/Chaskis/
+ arch = any
+ license = BSL
+ makedepends = nuget
+ makedepends = git
+ depends = mono>=4.2.2
+ optdepends = sqlite: For some Plugins
+ source = https://github.com/xforever1313/Chaskis/archive/0.3.0.tar.gz
+ sha256sums = 54C009DE0D22F6C249E7042FBF6A80DB9D723609943CEA67878352BC24340B6F
+
+pkgname = chaskis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56c08f667189
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Seth Hendrick <seth@shendrick.net>
+pkgname=chaskis
+pkgver=0.3.0
+pkgrel=1
+epoch=
+pkgdesc="A generic framework written in C# for making IRC Bots."
+arch=('any')
+url="https://github.com/xforever1313/Chaskis/"
+license=('BSL')
+groups=()
+depends=('mono>=4.2.2')
+makedepends=('nuget' 'git')
+checkdepends=()
+optdepends=("sqlite: For some Plugins")
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=()
+source=("https://github.com/xforever1313/Chaskis/archive/$pkgver.tar.gz")
+noextract=()
+sha256sums=('54C009DE0D22F6C249E7042FBF6A80DB9D723609943CEA67878352BC24340B6F')
+validpgpkeys=()
+
+prepare() {
+ echo "Nothing to prepare"
+}
+
+build() {
+ cd "$srcdir/Chaskis-$pkgver"
+ git clone https://github.com/xforever1313/sethcs SethCS
+ nuget restore ./Chaskis/Chaskis.sln
+ xbuild /p:Configuration=Release ./Chaskis/Chaskis.sln
+}
+
+check() {
+ cd "$srcdir/Chaskis-$pkgver/Chaskis"
+ mono ./packages/NUnit.ConsoleRunner.3.5.0/tools/nunit3-console.exe ./Tests/bin/Release/Tests.dll
+}
+
+package() {
+
+ cd "$srcdir/Chaskis-$pkgver"
+
+ mkdir -p $pkgdir/usr/lib
+
+ mono ./Chaskis/Install/ChaskisCliInstaller/bin/Release/ChaskisCliInstaller.exe ./Chaskis $pkgdir/usr/lib ./Chaskis/Install/windows/Product.wxs Release
+
+ # Systemd service
+ mkdir -p $pkgdir/usr/lib/systemd/user
+ cp ./Chaskis/Install/linux/systemd/chaskis.service $pkgdir/usr/lib/systemd/user/chaskis.service
+
+ # Binary
+ mkdir -p $pkgdir/usr/bin/
+ cp ./Chaskis/Install/linux/bin/chaskis $pkgdir/usr/bin/chaskis
+}
+
+pre_install() {
+ return
+}
+
+post_remove() {
+ return
+}
+