summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD42
-rw-r--r--chatterino.desktop9
-rw-r--r--chatterino.pngbin0 -> 2987 bytes
-rw-r--r--chatterino2-git.install17
5 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84279f1c9cee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = chatterino2-git
+ pkgdesc = Chatterino 2 is the second installment of the Twitch chat client series "Chatterino". dev/git version.
+ pkgver = r365.de332db
+ pkgrel = 1
+ url = https://chatterino.com
+ install = chatterino2-git.install
+ arch = any
+ license = MIT
+ makedepends = boost
+ makedepends = git
+ depends = rapidjson
+ depends = gst-plugins-ugly
+ depends = gst-plugins-good
+ depends = qt5-multimedia
+ depends = qt5-base
+ provides = chatterino
+ conflicts = chatterino
+ source = chatterino.png
+ source = chatterino.desktop
+ source = git://github.com/fourtf/chatterino2
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = chatterino2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..452b03658867
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Ckat <ckat@teknik.io>
+
+_name=chatterino2
+pkgname="$_name-git"
+pkgver=r365.de332db
+pkgrel=1
+pkgdesc='Chatterino 2 is the second installment of the Twitch chat client series "Chatterino". dev/git version.'
+arch=('any')
+url=https://chatterino.com
+license=('MIT')
+install=$pkgname.install
+provides=("${_name%2}")
+conflicts=("${_name%2}")
+depends=('rapidjson' 'gst-plugins-ugly' 'gst-plugins-good' 'qt5-multimedia' 'qt5-base')
+makedepends=('boost' 'git')
+source=("${_name%2}.png" "${_name%2}.desktop" "git://github.com/fourtf/$_name")
+sha1sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_name"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare () {
+ cd "$srcdir/$_name"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/$_name"
+ mkdir build
+ cd build
+ qmake ..
+ make
+}
+
+package() {
+ cd "$srcdir/$_name/build"
+ install -Dm755 ./"${_name%2}" "$pkgdir/usr/bin/${_name%2}"
+ install -Dm644 "$srcdir/${_name%2}.desktop" "$pkgdir/usr/share/applications/${_name%2}.desktop"
+ install -Dm644 "$srcdir/${_name%2}.png" "$pkgdir/usr/share/pixmaps/${_name%2}.png"
+}
diff --git a/chatterino.desktop b/chatterino.desktop
new file mode 100644
index 000000000000..828aa39d2ce7
--- /dev/null
+++ b/chatterino.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=Chatterino
+Comment=Chat client for twitch
+Exec=chatterino
+Icon=chatterino.png
+Terminal=false
+Type=Application
+Categories=Network;InstantMessaging;
diff --git a/chatterino.png b/chatterino.png
new file mode 100644
index 000000000000..837e2009e59a
--- /dev/null
+++ b/chatterino.png
Binary files differ
diff --git a/chatterino2-git.install b/chatterino2-git.install
new file mode 100644
index 000000000000..c3b3b3845d8f
--- /dev/null
+++ b/chatterino2-git.install
@@ -0,0 +1,17 @@
+post_install() {
+ cat << EOF
+
+==> Make sure you properly close chatterino after configuring, this is needed to save settings properly currently.
+
+(this may or may not still be the case at the time of installing this.)
+
+EOF
+}
+
+post_remove() {
+ cat << EOF
+
+==> To remove Chatterino settings, delete ~/.config/chatterino
+
+EOF
+}