summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD54
-rw-r--r--build.patch33
-rw-r--r--chatty_script3
-rw-r--r--config_dir.patch22
-rw-r--r--disable_version_check.patch73
-rw-r--r--manifest.patch6
7 files changed, 32 insertions, 182 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65b428e72dc2..40644d280314 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,23 @@
pkgbase = chatty
pkgdesc = Twitch Chat Client for Desktop
- pkgver = 0.8.7
- pkgrel = 8
+ pkgver = 0.9.1
+ pkgrel = 1
url = https://chatty.github.io/
arch = any
- license = MIT
- makedepends = apache-ant
- makedepends = java-environment>=8
+ license = GPL3
+ makedepends = gradle
depends = java-environment
depends = sh
optdepends = streamlink: for watching streams in a custom video player.
optdepends = livestreamer: for watching streams in a custom video player.
- source = chatty-0.8.7.tar.gz::https://github.com/chatty/chatty/archive/v0.8.7.tar.gz
+ source = chatty-0.9.1.tar.gz::https://github.com/chatty/chatty/archive/v0.9.1-emotefix.tar.gz
source = chatty.desktop
source = chatty_script
- source = config_dir.patch
- source = manifest.patch
source = disable_version_check.patch
- source = build.patch
- sha512sums = de772c4403f82cd66283eb340bce2cb62d5a7fd946cdfc46fbab9e3ec0858c3b8e08b5ec8db93efcb57a46f5b4422358a257069a260373228fa23b99d7dce5f1
+ sha512sums = 435041d7ad9893058d7d2a32fe669f746a679b3239c5e0e930f29766db4bfede19b84180dfef336ef200bfc84b36b93fd9d2a3ad99054cbeafba9154af4d6b51
sha512sums = 6b18009b4e34a2255cec42fd1e136e437aa528c80c40d9f1ab7379ab9e4a637fbd64860fb51e7e57aa0c74165b42f8d4c1ed6a1ffd061d07a02af1ec5167145e
- sha512sums = a2e3e61195c3bd9bb56ee7772a505e355d324cf86edfd41b0d92f261b77097eecf616e071c5cfed8bee7b4f779a5f1e126f9c8c2082a866e7a2e4bc4e4c0469c
- sha512sums = 5d56ac61a14342e5ea98e6d793d0455fbdf1f5ca5ac503ace5672b6a4182416051d39cfeea719152e907bbd16cb886b8edf2960914bd88f5f818094ec5388ebc
- sha512sums = 41aeb54f5705d5d612f779365a51b4df156b9ad8a6a282c271bf4d03f280ea7fe0470f2169896b6ef430d04f0f6bb5bcf16b2d6a0edaf2fc86847270e7179b91
- sha512sums = 69d8e2deec3feef312a04e5e4a6080d7aaad63cbd93d43eda8f1958ebbe65e79d38c6a65e3143669a37fb4af50a5960dfe7793ee9dce6b726096608f301a2fdf
- sha512sums = 3beb726fecfd7855be4fac50d4926bbcc8a44d0d1f43402443223cc90a743ba81968844a530fa37f38115fdf526bf05a60a331be862a3f452e909a2f5cb26ae7
+ sha512sums = b5ea9a3e77cf5ed006537348371619577aabf86bdb4e90b249c2e3a236b1f1d51920c6af2d2779920a0853cb4f5456fc0a10ad2a788c7c1e5b2649f7f2b756d0
+ sha512sums = 8df69baaf9a0bad68d7c1aac96877b65637c4688d59f9b36f4915b77e2ec9bfa99c67adfe69bca95baee88a585f6f01f5f26eb076079f95bfca9f0ac19180199
pkgname = chatty
diff --git a/PKGBUILD b/PKGBUILD
index 915db8b01c29..31fcc671da36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,49 @@
# Maintainer: Frederik “Freso” S. Olesen <archlinux@freso.dk>
# Contributor: Christoph Korn <christoph.korn at posteo dot de>
pkgname=chatty
-pkgver=0.8.7
-pkgrel=8
+pkgver=0.9.1
+pkgrel=1
pkgdesc='Twitch Chat Client for Desktop'
arch=('any')
url='https://chatty.github.io/'
-license=('MIT')
+license=('GPL3')
depends=('java-environment' 'sh')
optdepends=('streamlink: for watching streams in a custom video player.'
'livestreamer: for watching streams in a custom video player.')
-makedepends=('apache-ant' 'java-environment>=8')
-
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/chatty/chatty/archive/v${pkgver}.tar.gz"
+makedepends=('gradle')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/chatty/chatty/archive/v${pkgver}-emotefix.tar.gz"
"${pkgname}.desktop"
"${pkgname}_script"
- 'config_dir.patch'
- 'manifest.patch'
- 'disable_version_check.patch'
- 'build.patch')
-sha512sums=('de772c4403f82cd66283eb340bce2cb62d5a7fd946cdfc46fbab9e3ec0858c3b8e08b5ec8db93efcb57a46f5b4422358a257069a260373228fa23b99d7dce5f1'
+ 'disable_version_check.patch')
+sha512sums=('435041d7ad9893058d7d2a32fe669f746a679b3239c5e0e930f29766db4bfede19b84180dfef336ef200bfc84b36b93fd9d2a3ad99054cbeafba9154af4d6b51'
'6b18009b4e34a2255cec42fd1e136e437aa528c80c40d9f1ab7379ab9e4a637fbd64860fb51e7e57aa0c74165b42f8d4c1ed6a1ffd061d07a02af1ec5167145e'
- 'a2e3e61195c3bd9bb56ee7772a505e355d324cf86edfd41b0d92f261b77097eecf616e071c5cfed8bee7b4f779a5f1e126f9c8c2082a866e7a2e4bc4e4c0469c'
- '5d56ac61a14342e5ea98e6d793d0455fbdf1f5ca5ac503ace5672b6a4182416051d39cfeea719152e907bbd16cb886b8edf2960914bd88f5f818094ec5388ebc'
- '41aeb54f5705d5d612f779365a51b4df156b9ad8a6a282c271bf4d03f280ea7fe0470f2169896b6ef430d04f0f6bb5bcf16b2d6a0edaf2fc86847270e7179b91'
- '69d8e2deec3feef312a04e5e4a6080d7aaad63cbd93d43eda8f1958ebbe65e79d38c6a65e3143669a37fb4af50a5960dfe7793ee9dce6b726096608f301a2fdf'
- '3beb726fecfd7855be4fac50d4926bbcc8a44d0d1f43402443223cc90a743ba81968844a530fa37f38115fdf526bf05a60a331be862a3f452e909a2f5cb26ae7')
+ 'b5ea9a3e77cf5ed006537348371619577aabf86bdb4e90b249c2e3a236b1f1d51920c6af2d2779920a0853cb4f5456fc0a10ad2a788c7c1e5b2649f7f2b756d0'
+ '8df69baaf9a0bad68d7c1aac96877b65637c4688d59f9b36f4915b77e2ec9bfa99c67adfe69bca95baee88a585f6f01f5f26eb076079f95bfca9f0ac19180199')
prepare() {
cd "${pkgname}-${pkgver}"
- patch -p1 -i '../build.patch'
- patch -p1 -i '../config_dir.patch'
patch -p1 -i '../disable_version_check.patch'
- patch -p1 -i '../manifest.patch'
}
build() {
cd "chatty-${pkgver}"
- JAVA_HOME=/usr/lib/jvm/java-8-openjdk ant
+ gradle build
+ gradle release
}
package(){
- cd "${pkgname}-${pkgver}"
- install -Dm644 "./dist/${pkgname}.jar" "${pkgdir}/usr/share/${pkgname}/${pkgname}.jar"
- cp -a './assets' "${pkgdir}/usr/share/${pkgname}/"
+ mkdir "${srcdir}/Chatty_${pkgver}" && cd "${srcdir}/Chatty_${pkgver}"
+ bsdcpio -i -m --make-directories < "../${pkgname}-${pkgver}/build/releases/Chatty_${pkgver}.zip"
+ install -Dm644 'Chatty.jar' "${pkgdir}/usr/share/${pkgname}/Chatty.jar"
+ cp -a 'img' 'sounds' "${pkgdir}/usr/share/${pkgname}/"
+ install -Dm644 'readme.txt' "${pkgdir}/usr/share/doc/${pkgname}/readme.txt"
- install -Dm755 "../${pkgname}_script" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 './src/chatty/gui/app_16.png' "${pkgdir}/usr/share/icons/hicolor/16x16/apps/${pkgname}.png"
- install -Dm644 './src/chatty/gui/app_64.png' "${pkgdir}/usr/share/icons/hicolor/64x64/apps/${pkgname}.png"
- install -Dm644 "../${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ cd "${srcdir}"
+ install -Dm755 "${pkgname}_script" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 './APACHE_LICENSE' "${pkgdir}/usr/share/licenses/${pkgname}/APACHE_LICENSE"
- install -Dm644 './LGPL' "${pkgdir}/usr/share/licenses/${pkgname}/LGPL"
- install -Dm644 './README.md' "${pkgdir}/usr/share/licenses/${pkgname}/MIT"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm644 "./src/chatty/gui/app_main_16.png" "${pkgdir}/usr/share/icons/hicolor/16x16/apps/${pkgname}.png"
+ install -Dm644 "./src/chatty/gui/app_main_64.png" "${pkgdir}/usr/share/icons/hicolor/64x64/apps/${pkgname}.png"
+ install -Dm644 "./src/chatty/gui/app_main_128.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/${pkgname}.png"
}
-
diff --git a/build.patch b/build.patch
deleted file mode 100644
index 21dba0f874f2..000000000000
--- a/build.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Nur chatty-0.8.4.orig/build.xml chatty-0.8.4/build.xml
---- chatty-0.8.4.orig/build.xml 1970-01-01 01:00:00.000000000 +0100
-+++ chatty-0.8.4/build.xml 2016-10-24 22:23:20.312077302 +0200
-@@ -0,0 +1,29 @@
-+<project name="chatty" default="jar">
-+ <target name="clean">
-+ <delete dir="bin"/>
-+ <delete dir="dist"/>
-+ <delete dir="assets/lib/dlls"/>
-+ </target>
-+
-+ <target name="compile" depends="clean">
-+ <mkdir dir="bin"/>
-+ <javac srcdir="src/chatty" encoding="utf-8" destdir="bin">
-+ <classpath>
-+ <fileset dir="assets/lib">
-+ <include name="**/*.jar" />
-+ </fileset>
-+ </classpath>
-+ </javac>
-+ <copy todir="bin">
-+ <fileset dir="src" excludes="**/*.java"/>
-+ </copy>
-+ </target>
-+
-+ <target name="jar" depends="compile">
-+ <mkdir dir="dist"/>
-+ <jar manifest="manifest.mf" destfile="dist/chatty.jar">
-+ <fileset dir="bin" />
-+ <zipgroupfileset dir="assets/lib" />
-+ </jar>
-+ </target>
-+ </project>
diff --git a/chatty_script b/chatty_script
index ad18eb9d2436..258342ff7729 100644
--- a/chatty_script
+++ b/chatty_script
@@ -1,4 +1,3 @@
#!/bin/sh
cd /usr/share/chatty
-export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH
-java -jar chatty.jar "$@"
+java -jar Chatty.jar "$@"
diff --git a/config_dir.patch b/config_dir.patch
deleted file mode 100644
index 6a29db3e269a..000000000000
--- a/config_dir.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-# change config directory to $HOME/.config/chatty
-Index: chatty-0.8.2/src/chatty/Chatty.java
-===================================================================
---- chatty-0.8.2.orig/src/chatty/Chatty.java 2016-04-26 22:43:29.316678569 +0200
-+++ chatty-0.8.2/src/chatty/Chatty.java 2016-04-26 22:44:05.245414029 +0200
-@@ -186,12 +186,11 @@
- * @return
- */
- public static String getUserDataDirectory() {
-- if (useCurrentDirectory) {
-- return System.getProperty("user.dir") + File.separator;
-- }
- String dir = System.getProperty("user.home")
-- + File.separator
-- + ".chatty"
-+ + File.separator
-+ + ".config"
-+ + File.separator
-+ + "chatty"
- + File.separator;
- new File(dir).mkdirs();
- return dir;
diff --git a/disable_version_check.patch b/disable_version_check.patch
index 6eb142c5e585..86e5d3dae02a 100644
--- a/disable_version_check.patch
+++ b/disable_version_check.patch
@@ -12,76 +12,3 @@ Index: chatty-0.8.2/src/chatty/Chatty.java
/**
* The regular URL of the textfile where the most recent version is stored.
-Index: chatty-0.8.2/src/chatty/TwitchClient.java
-===================================================================
---- chatty-0.8.2.orig/src/chatty/TwitchClient.java 2016-04-26 22:47:26.953580371 +0200
-+++ chatty-0.8.2/src/chatty/TwitchClient.java 2016-04-26 22:51:15.054348837 +0200
-@@ -298,7 +298,7 @@
- checkForVersionChange();
- // Check version, if enabled in this build
- if (Chatty.VERSION_CHECK_ENABLED) {
-- checkNewVersion();
-+ //checkNewVersion();
- }
-
- // Connect or open connect dialog
-@@ -368,44 +368,7 @@
- * Checks for a new version if the last check was long enough ago.
- */
- private void checkNewVersion() {
-- if (!settings.getBoolean("checkNewVersion")) {
-- return;
-- }
-- /**
-- * Check if enough time has passed since the last check.
-- */
-- long ago = System.currentTimeMillis() - settings.getLong("versionLastChecked");
-- if (ago/1000 < CHECK_VERSION_INTERVAL) {
-- /**
-- * If not checking, check if update was detected last time.
-- */
-- String updateAvailable = settings.getString("updateAvailable");
-- if (!updateAvailable.isEmpty()) {
-- g.setUpdateAvailable(updateAvailable);
-- }
-- return;
-- }
-- settings.setLong("versionLastChecked", System.currentTimeMillis());
-- g.printSystem("Checking for new version..");
--
-- new Version(new VersionListener() {
-
-- @Override
-- public void versionChecked(String version, String info, boolean isNewVersion) {
-- if (isNewVersion) {
-- String infoText = "";
-- if (!info.isEmpty()) {
-- infoText = "[" + info + "] ";
-- }
-- g.printSystem("New version available: "+version+" "+infoText
-- +"(Go to <Help-Website> to download)");
-- g.setUpdateAvailable(version);
-- settings.setString("updateAvailable", version);
-- } else {
-- g.printSystem("You already have the newest version.");
-- }
-- }
-- });
- }
-
- /**
-Index: chatty-0.8.2/src/chatty/Version.java
-===================================================================
---- chatty-0.8.2.orig/src/chatty/Version.java 2016-04-26 22:47:26.953580371 +0200
-+++ chatty-0.8.2/src/chatty/Version.java 2016-04-26 22:51:48.071042729 +0200
-@@ -32,8 +32,8 @@
- }
-
- private void checkForNewVersion() {
-- LOGGER.info("Checking for new version..");
-- new Thread(new VersionChecker()).start();
-+ //LOGGER.info("Checking for new version..");
-+ //new Thread(new VersionChecker()).start();
- }
-
- /**
diff --git a/manifest.patch b/manifest.patch
deleted file mode 100644
index e68f68782e8c..000000000000
--- a/manifest.patch
+++ /dev/null
@@ -1,6 +0,0 @@
-diff -Nur chatty-0.8.4.orig/manifest.mf chatty-0.8.4/manifest.mf
---- chatty-0.8.4.orig/manifest.mf 1970-01-01 01:00:00.000000000 +0100
-+++ chatty-0.8.4/manifest.mf 2016-10-24 22:20:19.004420770 +0200
-@@ -0,0 +1,2 @@
-+Manifest-Version: 1.0
-+Main-Class: chatty.Chatty