summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6124abf930cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = check_pidfile
+ pkgdesc = check pidfile
+ pkgver = 1
+ pkgrel = 0
+ url = https://github.com/hollow/check_pidfile.git
+ arch = i686
+ arch = x86_64
+ depends = monitoring-plugins
+ source = git+https://github.com/hollow/check_pidfile.git
+ md5sums = SKIP
+
+pkgname = check_pidfile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f30de20e6dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Andreas Nüßlein <nutz@noova.de>
+
+pkgname=check_pidfile
+pkgver=1
+pkgrel=0
+pkgdesc="check pidfile"
+arch=('i686' 'x86_64')
+depends=('monitoring-plugins')
+url="https://github.com/hollow/check_pidfile.git"
+source=("git+https://github.com/hollow/check_pidfile.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ autoreconf -vi
+ ./configure
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm4755 check_pidfile "$pkgdir/usr/lib/monitoring-plugins/check_pidfile"
+}
+
+# vim: ft=sh syn=sh