summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f85bf38d262b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Sep 8 00:36:23 UTC 2016
+pkgbase = check_smartmon-git
+ pkgdesc = Nagios-Plugin that uses smartmontools (http://smartmontools.sourceforge.net/) to check disk health status and temperature.
+ pkgver = r25.c1569c3
+ pkgrel = 1
+ url = https://github.com/nihlaeth/Nagios_check_smartmon
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = python2
+ depends = python2-psutil
+ source = check_smartmon-git::git+https://github.com/nihlaeth/Nagios_check_smartmon.git
+ sha256sums = SKIP
+
+pkgname = check_smartmon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98df0b277081
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+pkgname=check_smartmon-git
+pkgver=r25.c1569c3
+pkgrel=1
+pkgdesc="Nagios-Plugin that uses smartmontools (http://smartmontools.sourceforge.net/) to check disk health status and temperature."
+arch=('i686' 'x86_64')
+url="https://github.com/nihlaeth/Nagios_check_smartmon"
+license=('GPL2')
+depends=('python2' 'python2-psutil')
+source=("${pkgname}::git+https://github.com/nihlaeth/Nagios_check_smartmon.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ msg 'Fixing Python version...'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python$#/usr/bin/python2#g'
+}
+
+package() {
+ # Install License
+ install -Dm644 "$pkgname/LICENCE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Put code files into '/usr/share'
+ install -Dm755 "$pkgname/check_smartmon.py" "$pkgdir/usr/share/check_smartmon/check_smartmon.py"
+
+ # Install binary
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/check_smartmon/check_smartmon.py" "${pkgdir}/usr/bin/check_smartmon"
+}