summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD17
2 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68f1e88b1dc3..525fd3724365 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = checkpolicy
pkgdesc = SELinux policy compiler
- pkgver = 2.9
+ pkgver = 3.6
pkgrel = 1
- url = http://userspace.selinuxproject.org
+ url = https://github.com/SELinuxProject/selinux
arch = i686
arch = x86_64
+ arch = aarch64
groups = selinux
license = GPL2
- makedepends = libsepol>=2.9
- provides = selinux-usr-checkpolicy=2.9-1
+ makedepends = libsepol>=3.6
+ provides = selinux-usr-checkpolicy=3.6-1
conflicts = selinux-usr-checkpolicy
- source = https://github.com/SELinuxProject/selinux/releases/download/20190315/checkpolicy-2.9.tar.gz
- sha256sums = a946c32b284532447857e4c48830f8816867c61220c8c08bdd32e6f691335f8e
+ source = https://github.com/SELinuxProject/selinux/releases/download/3.6/checkpolicy-3.6.tar.gz
+ source = https://github.com/SELinuxProject/selinux/releases/download/3.6/checkpolicy-3.6.tar.gz.asc
+ validpgpkeys = 63191CE94183098689CAB8DB7EF137EC935B0EAF
+ validpgpkeys = B8682847764DF60DF52D992CBC3905F235179CF1
+ sha256sums = 1b346b3cdd4f8a78a157627bad64a3b3479c67b6a19d15e6d5c8694620eadbc1
+ sha256sums = SKIP
pkgname = checkpolicy
-
diff --git a/PKGBUILD b/PKGBUILD
index 7b959fdd3ef9..42e7a20e2fd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,18 +7,23 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=checkpolicy
-pkgver=2.9
+pkgver=3.6
pkgrel=1
pkgdesc="SELinux policy compiler"
-arch=('i686' 'x86_64')
-url='http://userspace.selinuxproject.org'
+arch=('i686' 'x86_64' 'aarch64')
+url='https://github.com/SELinuxProject/selinux'
license=('GPL2')
groups=('selinux')
-makedepends=('libsepol>=2.9')
+makedepends=('libsepol>=3.6')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/20190315/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('a946c32b284532447857e4c48830f8816867c61220c8c08bdd32e6f691335f8e')
+validpgpkeys=(
+ '63191CE94183098689CAB8DB7EF137EC935B0EAF' # Jason Zaman <perfinion@gentoo.org>
+ 'B8682847764DF60DF52D992CBC3905F235179CF1' # Petr Lautrbach <plautrba@redhat.com>
+)
+source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"{,.asc})
+sha256sums=('1b346b3cdd4f8a78a157627bad64a3b3479c67b6a19d15e6d5c8694620eadbc1'
+ 'SKIP')
build() {
cd "${pkgname}-${pkgver}"