summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffd9eb4d5ba5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = checkpolicy
+ pkgdesc = SELinux policy compiler
+ pkgver = 2.2
+ pkgrel = 1
+ url = http://userspace.selinuxproject.org
+ arch = i686
+ arch = x86_64
+ groups = selinux
+ license = GPL
+ depends = libsepol>=2.2
+ depends = libselinux>=2.2
+ options = !emptydirs
+ source = http://userspace.selinuxproject.org/releases/20131030/checkpolicy-2.2.tar.gz
+ sha256sums = 9ff6698f4d4cb59c9c916e348187d533ada4107f90c253ef7304905934e9adf8
+
+pkgname = checkpolicy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..877811d6168a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Timothée Ravier <tim@siosm.fr>
+# Contributor: Nicky726 (Nicky726 <at> gmail <dot> com)
+# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
+
+pkgname=checkpolicy
+pkgver=2.2
+pkgrel=1
+pkgdesc="SELinux policy compiler"
+arch=('i686' 'x86_64')
+url='http://userspace.selinuxproject.org'
+license=('GPL')
+groups=('selinux')
+depends=('libsepol>=2.2' 'libselinux>=2.2')
+#makedepends=('selinux-flex')
+options=(!emptydirs)
+source=("http://userspace.selinuxproject.org/releases/20131030/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('9ff6698f4d4cb59c9c916e348187d533ada4107f90c253ef7304905934e9adf8')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ make
+}
+
+package(){
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}