summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f429722e9dcc..cc0c2602202e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = checkpolicy
pkgdesc = SELinux policy compiler
pkgver = 2.2
- pkgrel = 1
+ pkgrel = 2
url = http://userspace.selinuxproject.org
arch = i686
arch = x86_64
groups = selinux
license = GPL
- depends = libsepol>=2.2
- depends = libselinux>=2.2
- provides = selinux-usr-checkpolicy=2.2-1
+ depends = libsepol
+ depends = libselinux
+ provides = selinux-usr-checkpolicy=2.2-2
conflicts = selinux-usr-checkpolicy
options = !emptydirs
source = http://userspace.selinuxproject.org/releases/20131030/checkpolicy-2.2.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index ef8bddc39fec..f0cd41df1d32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=checkpolicy
pkgver=2.2
-pkgrel=1
+pkgrel=2
pkgdesc="SELinux policy compiler"
arch=('i686' 'x86_64')
url='http://userspace.selinuxproject.org'
license=('GPL')
groups=('selinux')
-depends=('libsepol>=2.2' 'libselinux>=2.2')
+depends=('libsepol' 'libselinux')
#makedepends=('selinux-flex')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
@@ -26,4 +26,6 @@ build() {
package(){
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
+ install -m 0755 test/dismod "${pkgdir}"/usr/bin/sedismod
+ install -m 0755 test/dispol "${pkgdir}"/usr/bin/sedispol
}