summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD15
-rwxr-xr-xcheckupdates+aur.bash2
4 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d295fa567545
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Sat Jan 28 16:31:27 UTC 2017
+pkgbase = checkupdates+aur
+ pkgdesc = combines checkupdates and checkupdates-aur with separator as argument
+ pkgver = 1
+ pkgrel = 1
+ arch = any
+ license = LGPL3
+ depends = checkupdates-aur
+ source = checkupdates+aur.bash
+ sha512sums = c2fbcb0845e8f1b77d1414fc28c4f38693ef5460025cd317ddbd4940724b2b1045c8deed3d73233af49bda83864aa8e5915956712efe70355e3ffcefc605e837
+
+pkgname = checkupdates+aur
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3ad5858c5d4b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/src/
+/pkg/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eea54095573a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Norbert Pfeiler <norbert.pfeiler+aur ät gmail.com>
+
+pkgname=checkupdates+aur
+pkgver=1
+pkgrel=1
+pkgdesc='combines checkupdates and checkupdates-aur with separator as argument'
+arch=('any')
+license=('LGPL3')
+depends=('checkupdates-aur')
+source=("checkupdates+aur.bash")
+sha512sums=('c2fbcb0845e8f1b77d1414fc28c4f38693ef5460025cd317ddbd4940724b2b1045c8deed3d73233af49bda83864aa8e5915956712efe70355e3ffcefc605e837')
+
+package() {
+ install -D -m755 "$srcdir/checkupdates+aur.bash" "$pkgdir/usr/bin/checkupdates+aur"
+}
diff --git a/checkupdates+aur.bash b/checkupdates+aur.bash
new file mode 100755
index 000000000000..7497a9a5a3e6
--- /dev/null
+++ b/checkupdates+aur.bash
@@ -0,0 +1,2 @@
+#!/usr/bin/bash
+/usr/bin/checkupdates && printf "$1" && /usr/bin/checkupdates-aur