summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore4
-rw-r--r--Makefile18
2 files changed, 22 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f05a7493bf44
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.deb
+/*.tar.xz
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..c81415812ee3
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+default: build
+
+build: namcap
+ makepkg
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ git clean -fd
+ rm -rf pkg src *.deb *.tar.xz
+
+namcap:
+ namcap PKGBUILD
+
+# too many failures we can't correct due to PKGBUILD design
+shellcheck:
+ shellcheck PKGBUILD
+
+vet: namcap shellcheck