summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7024f7ed9511..289f04fac2c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,9 @@
# Maintainer: Томас <70m4c@70m4c.su>
+# shellcheck disable=SC2148 # Ignore lack of shebang
+# shellcheck disable=SC2034 # Ignore "unused" PKGBUILD variables
+# shellcheck disable=SC2154 # Ignore "unassigned" references to $srcdir and $pkgdir
+
pkgname=chef-server
pkgver=13.2.0
pkgrel=1
@@ -13,7 +17,7 @@ source=("https://packages.chef.io/files/stable/chef-server/${pkgver}/ubuntu/18.0
sha256sums=('c80d63471e173188f656ff36e74afbbc97524f764f3a41cdcc51bd4fedc659a8')
package() {
- cd "$srcdir"
+ cd "$srcdir" || exit 1
bsdtar -xf data.tar.xz -C "$pkgdir"
install -Dm644 "$pkgdir/opt/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
@@ -21,11 +25,11 @@ package() {
# link executables
binaries="chef-apply chef-client chef-server-ctl chef-shell chef-solo gather-logs knife ohai"
- mkdir -p $pkgdir/usr/bin
+ mkdir -p "$pkgdir/usr/bin"
for binary in $binaries; do
- ln -s /opt/opscode/bin/$binary $pkgdir/usr/bin/ || error_exit "Cannot link $binary to /usr/bin"
+ ln -s "/opt/opscode/bin/$binary" "$pkgdir/usr/bin/" || error_exit "Cannot link $binary to /usr/bin"
done
- chown -Rh 0:0 $pkgdir
- chmod 755 $pkgdir/opt
+ chown -Rh 0:0 "$pkgdir"
+ chmod 755 "$pkgdir/opt"
}