summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD59
2 files changed, 27 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b38afa93fad..38b5ff6a4705 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = cherrytree-git
pkgdesc = Hierarchical note-taking application, git version
- pkgver = 0.99.51.r2.gd54dd23e
+ pkgver = 1.1.2.r5.g4db6074c
pkgrel = 1
url = https://github.com/giuspen/cherrytree
arch = x86_64
- license = GPL3
- checkdepends = gmock
+ license = GPL-3.0-or-later
checkdepends = gtest
makedepends = cmake
makedepends = git
@@ -17,7 +16,6 @@ pkgbase = cherrytree-git
depends = libxml++2.6
depends = uchardet
depends = vte3
- optdepends = xorg-xhost: allow chroot access to X server for running tests
provides = cherrytree
conflicts = cherrytree
source = git+https://github.com/giuspen/cherrytree.git
diff --git a/PKGBUILD b/PKGBUILD
index 660007442dba..e9581fe4d998 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,47 @@
# Maintainer: Morgenstern <charles [at] charlesbwise [dot] com>
pkgname=cherrytree-git
-_pkgname="${pkgname%%-git}"
-pkgver=0.99.51.r2.gd54dd23e
+pkgver=1.1.2.r5.g4db6074c
pkgrel=1
pkgdesc="Hierarchical note-taking application, git version"
arch=('x86_64')
-url="https://github.com/giuspen/${_pkgname}"
-license=('GPL3')
+url="https://github.com/giuspen/${pkgname%%-git}"
+license=('GPL-3.0-or-later')
depends=('fmt'
- 'gspell'
- 'gtksourceviewmm'
- 'libxml++2.6'
- 'uchardet'
- 'vte3')
+ 'gspell'
+ 'gtksourceviewmm'
+ 'libxml++2.6'
+ 'uchardet'
+ 'vte3')
makedepends=('cmake'
- 'git'
- 'python'
- 'spdlog')
-checkdepends=('gmock'
- 'gtest')
-optdepends=('xorg-xhost: allow chroot access to X server for running tests')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source=("git+https://github.com/giuspen/${_pkgname}.git")
+ 'git'
+ 'python'
+ 'spdlog')
+checkdepends=('gtest')
+provides=("${pkgname%%-git}")
+conflicts=("${pkgname%%-git}")
+source=("git+https://github.com/giuspen/${pkgname%%-git}.git")
sha512sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname%%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
}
build() {
cmake \
- -B "${_pkgname}/build" \
- -S "${_pkgname}" \
- -DAUTO_RUN_TESTING:BOOL='OFF' \
- -DUSE_SHARED_GTEST_GMOCK:BOOL='ON' \
- -Wno-dev
- make -C "${_pkgname}/build"
+ -B "${pkgname%%-git}/build" \
+ -S "${pkgname%%-git}" \
+ -DAUTO_RUN_TESTING:BOOL='OFF' \
+ -DUSE_SHARED_GTEST_GMOCK:BOOL='ON' \
+ -Wno-dev
+ make -C "${pkgname%%-git}/build"
}
-# NOTE: In order to run tests that depend on the X server in a clean chroot,
-# you must allow the chroot access your X server:
-# xhost +local:
-# https://wiki.archlinux.org/index.php/chroot#Run_graphical_applications_from_chroot
check() {
- export DISPLAY=:0
- ./"${_pkgname}/build/run_tests_with_x_1"
- ./"${_pkgname}/build/run_tests_with_x_2"
+ ./"${pkgname%%-git}/build/run_tests_no_x"
}
package() {
- make -C "${_pkgname}/build" DESTDIR="${pkgdir}" install
+ make -C "${pkgname%%-git}/build" DESTDIR="${pkgdir}" install
}